VirtualBox

Ticket #4739 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

Win2k3 server fails to boot if disk attached to SATAx => fixed in svn

Reported by: gemisigo Owned by:
Priority: major Component: virtual disk
Version: VirtualBox 3.0.4 Keywords: SATA disk fails to boot to win2k3 server
Cc: Guest type: Windows
Host type: Windows

Description

I've had my guest system (win2k3 server enterprise edition) set up as the following:

SATA0 10GB system disk,
SATA1 2GB dbdata,
STAT2 2GB otherdata.

Under 3.0.2 it was working normally, under 3.0.4 it starts to boot and then locks up.

The session information shows that it happens after writing 1024 bytes to SATA port 0.

Setting the IDE0MasterEmulationPort to other than 0 (i.e. the port of the system disk) makes the vm fail to boot completely with message "FATAL: No bootable medium found! System halted!". Under 3.0.2 it made no difference.

There is a slightly similar problem under ticket #4695 but the guests there are not the same, the guest does not seem to be suspended, it simply hangs and its solution does not apply in my case.

Attachments

Copy of VBox.log Download (37.7 KB) - added by gemisigo 5 years ago.
This is the log file right after it froze.

Change History

Changed 5 years ago by gemisigo

This is the log file right after it froze.

comment:1 Changed 5 years ago by aeichner

  • Summary changed from Win2k3 server fails to boot if disk attached to SATAx to Win2k3 server fails to boot if disk attached to SATAx => fixed in svn

This is fixed in svn and will appear in the next maintenance release. Thanks for the report.

comment:2 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use