VirtualBox

Ticket #4710 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

SATA "fix" in 3.0.4 breaks working SATA => Fixed in SVN/3.0.6

Reported by: mooninite Owned by:
Priority: major Component: guest additions
Version: VirtualBox 3.0.4 Keywords:
Cc: Guest type: other
Host type: Linux

Description

Whatever bug 4342 "fixed" broke my working SATA. After updating 3.0.4 I booted OK, but after installation of the additions, XP BSOD'd on boot. I switched from SATA to IDE and XP booted.

BTW, how did bug 4342 get fixed so quickly when bug 2282, which looks the same, was considered non-fixable?

Host: Fedora 11 32-bit

Guest: Windows XP SP3 with all latest updates applied. Intel SATA AHCI 8.7 driver installed. Has worked since 2.x and 3.0.0 and 3.0.2. Worked with 3.0.4 without additions installed.

Attachments

PCVDEV-2009-08-07-09-04-54.log Download (69.1 KB) - added by mooninite 5 years ago.
vbox.log
VBox.log Download (79.2 KB) - added by ktp 5 years ago.
bsod.png Download (7.7 KB) - added by ktp 5 years ago.
driver.2.png Download (44.6 KB) - added by ktp 5 years ago.

Change History

Changed 5 years ago by mooninite

vbox.log

comment:1 Changed 5 years ago by homer-mad

I am seeing the exact same issue. Windows XP SP3 vm boots fine before loading guest additions using Sata. After loading additions, BSOD. Can load fine using IDE.

Using same SATA AHCI 8.7 driver.

Host: Fedora 11 64-Bit

Guest: Windows XP SP3

comment:2 Changed 5 years ago by mooninite

Reinstalling the SATA driver and then switching the hard drive image back to SATA lets you boot.

After that I updated to the 8.9 driver and it works, too.

It's still a nasty bug when installing the additions screw up your VM.

comment:3 Changed 5 years ago by ktp

I didn't try upgrading SATA driver or Guest Additions yet, but powering down the XP VM completely and starting it gives no BSOD. If I restart XP from within the VM I get the BSOD. If I have a little more time I'll add further Information.

Changed 5 years ago by ktp

comment:4 Changed 5 years ago by ktp

Uninstalling the 3.0.0 Guest Additions which I hadn't updated didn't help in my case. Installing the 3.0.4 additions and upgrading SATA Driver (Intel Matrix Storage Manager) from 8.8 to 8.9 also didn't fix it. Still on a restart the BSOD occurs.

@homer-mad & @mooninite: have you tried restarting XP after you updated/reinstalled drivers and/or additions with the drive switched back to SATA?

Changed 5 years ago by ktp

Changed 5 years ago by ktp

comment:5 Changed 5 years ago by aeichner

I could reproduce the problem ktp described. This will be fixed in the next maintenance release. Can the others confirm that shutting down the VM completely and starting it again instead of just rebooting the guest works?

comment:6 Changed 5 years ago by mooninite

I have shutdown and started my XP VM twice now with the hard drive set to SATA, 8.9 driver, and 3.0.4 additions installed. No problems.

I restarted the XP VM with the hard drive set to SATA and got the BSOD again. Powered off and started from a cold start and that worked fine.

Yes, it seems to be a restart issue and not related to the driver/additions.

comment:7 Changed 5 years ago by frank

  • Summary changed from SATA "fix" in 3.0.4 breaks working SATA to SATA "fix" in 3.0.4 breaks working SATA => Fixed in SVN/3.0.6

comment:8 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use