VirtualBox

Ticket #4698 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

hostonlyifs fails if there is no physical network on host => Fixed in SVN/3.0.6

Reported by: robbies Owned by:
Priority: major Component: network/hostif
Version: VirtualBox 3.0.4 Keywords:
Cc: murgey; greenrd Guest type: Linux
Host type: Mac OS X

Description

Hi guys,

VirtualBox seems unable to find the host-only interface if the host has no physical network connection WiFi/Ethernet. This bug might be related to #4637 and perhaps even to #4567.

When offline the virtual interface vanishes everywhere: in VirtualBox Settings, in VM-Settings, in CLI (see below)

VBox-Log:

00:00:00.449 NetworkAttachmentType_HostOnly: COMGETTER(HostInterface):  NetworkAttachmentType_HostOnly: FindByName failed, rc (0x80004005)ERROR [COM]: aRC=NS_ERROR_FAILURE (0x80004005) aIID={0a51994b-cbc6-4686-94eb-d4e4023280e2} aComponent={Console} aText={Inexistent host networking interface, name 'vboxnet0' (VERR_INTERNAL_ERROR).
00:00:00.461 Unknown error creating VM (VERR_INTERNAL_ERROR)} aWarning=false, preserve=false
00:00:00.495 Power up failed (vrc=VERR_INTERNAL_ERROR, rc=NS_ERROR_FAILURE (0X80004005))

Bug triggered from CLI:

macrob:fespa robbie$ sudo ifconfig en1 up
macrob:fespa robbie$ VBoxManage list hostonlyifs
VirtualBox Command Line Management Interface Version 3.0.2
(C) 2005-2009 Sun Microsystems, Inc.
All rights reserved.

Name:            vboxnet0
GUID:            786f6276-656e-4074-8000-007662000000
Dhcp:            Disabled
IPAddress:       192.168.254.1
NetworkMask:     255.255.255.0
IPV6Address:     
IPV6NetworkMaskPrefixLength: 0
HardwareAddress: 00:76:62:00:00:00
MediumType:      Ethernet
Status:          Up
VBoxNetworkName: HostInterfaceNetworking-vboxnet0

macrob:fespa robbie$ sudo ifconfig en0 down
macrob:fespa robbie$ VBoxManage list hostonlyifs
VirtualBox Command Line Management Interface Version 3.0.2
(C) 2005-2009 Sun Microsystems, Inc.
All rights reserved.

Context: "FindHostNetworkInterfacesOfType(HostNetworkInterfaceType_HostOnly, ComSafeArrayAsOutParam(hostNetworkInterfaces))" at line 320 of file VBoxManageList.cpp
macrob:fespa robbie$ sudo ifconfig en0 up
macrob:fespa robbie$ VBoxManage list hostonlyifs
VirtualBox Command Line Management Interface Version 3.0.2
(C) 2005-2009 Sun Microsystems, Inc.
All rights reserved.

Name:            vboxnet0
GUID:            786f6276-656e-4074-8000-007662000000
Dhcp:            Disabled
IPAddress:       192.168.254.1
NetworkMask:     255.255.255.0
IPV6Address:     
IPV6NetworkMaskPrefixLength: 0
HardwareAddress: 00:76:62:00:00:00
MediumType:      Ethernet
Status:          Up
VBoxNetworkName: HostInterfaceNetworking-vboxnet0

Just tried it again with 3.0.4 - same error

macrob:fespa robbie$ VBoxManage list hostonlyifs
VirtualBox Command Line Management Interface Version 3.0.4
(C) 2005-2009 Sun Microsystems, Inc.
All rights reserved.

Name:            vboxnet0
GUID:            786f6276-656e-4074-8000-007662000000
Dhcp:            Disabled
IPAddress:       192.168.254.1
NetworkMask:     255.255.255.0
IPV6Address:     
IPV6NetworkMaskPrefixLength: 0
HardwareAddress: 00:76:62:00:00:00
MediumType:      Ethernet
Status:          Down
VBoxNetworkName: HostInterfaceNetworking-vboxnet0

macrob:fespa robbie$ VBoxManage list hostonlyifs
VirtualBox Command Line Management Interface Version 3.0.4
(C) 2005-2009 Sun Microsystems, Inc.
All rights reserved.

Context: "FindHostNetworkInterfacesOfType(HostNetworkInterfaceType_HostOnly, ComSafeArrayAsOutParam(hostNetworkInterfaces))" at line 320 of file VBoxManageList.cpp
macrob:fespa robbie$ VBoxManage list hostonlyifs
VirtualBox Command Line Management Interface Version 3.0.4
(C) 2005-2009 Sun Microsystems, Inc.
All rights reserved.

Context: "FindHostNetworkInterfacesOfType(HostNetworkInterfaceType_HostOnly, ComSafeArrayAsOutParam(hostNetworkInterfaces))" at line 320 of file VBoxManageList.cpp
macrob:fespa robbie$ sudo ifconfig en0 up
macrob:fespa robbie$ VBoxManage list hostonlyifs
VirtualBox Command Line Management Interface Version 3.0.4
(C) 2005-2009 Sun Microsystems, Inc.
All rights reserved.

Name:            vboxnet0
GUID:            786f6276-656e-4074-8000-007662000000
Dhcp:            Disabled
IPAddress:       192.168.254.1
NetworkMask:     255.255.255.0
IPV6Address:     
IPV6NetworkMaskPrefixLength: 0
HardwareAddress: 00:76:62:00:00:00
MediumType:      Ethernet
Status:          Down
VBoxNetworkName: HostInterfaceNetworking-vboxnet0

Thanks for help! robbie

Change History

comment:1 Changed 5 years ago by socratis

Hi Robbie (and everyone else),

I noticed the same thing, but I believe it was with version 3.0.0 (although I might be wrong on this one) and I only observed it with the GUI, not with the CLI like your excellent investigation.

BUT, (there's always one but)

It seems to happen not only with the HostOnly interface but with the BridgedAdapter as well. Will check for the NAT option and report back...

Socratis

comment:2 Changed 5 years ago by robbies

Hi Socratis,

thanks for the reply! The bug seems to lie in the network adapter discovery part of VBox. For me it would make sence that the BridgedApater will not work, if the corresponding physical adapter is down and that's not a problem for me (same for the NAT case). VMWare behaves similar I think, but more user-friendly: when the physical adapter is down, you get an info message at startup of the VM and the VM-NIC gets simply not connected. The VirtualBox behaviour, telling you simply that your configuration is wrong, is less user-friendly and should be improved but in my opinion not a real bug.

The real bug for me is, that you're unable to start a VM with a network connection to the host while travelling. It made it impossible for me to work if I forgot to start the VM before departure.

Yesterday I found a simple workaround, which I like to share with everyone having the same problem: Simply create an Ad-hoc network with your WiFi adapter, wait a few seconds, start the VM, and than you can deactivate it again.

But hopefully someone will fix the issue soon...

robbie

comment:3 Changed 5 years ago by sjbufton

As a potential help: this is a regression between VirtualBox 2.2.4 and 3.0.x. I held off upgrading to 3.0.x because I was working on an important project (never touch a running system!). Upgrading to 3.0.4 caused my VMs to fail when disconnected from a physical network. I downgraded to 2.2.4 again, and vboxnet0 works fine again, whether there is a physical network present or not.

comment:4 Changed 5 years ago by frank

  • Summary changed from hostonlyifs fails if there is no physical network on host to hostonlyifs fails if there is no physical network on host => Fixed in SVN/3.0.6

comment:5 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use