VirtualBox

Ticket #4596 (closed defect: invalid)

Opened 5 years ago

Last modified 5 years ago

Ubuntu 9.04 Server network not working

Reported by: iPegasus Owned by:
Priority: major Component: network
Version: VirtualBox 3.0.2 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description

Windows XP SP3 Host and Ubuntu 9.04 Server Guest

Guest was instaled in nat mode. However, when network mode was changed to bridge mode, network stop functioning. I found that the problem was related with UDEV due the following message: udev: renamed network interface eth0 to eth1.

On MacOS X Leopard this problem doesn't happen.

Change History

comment:1 Changed 5 years ago by frank

This is actually not a bug of VirtualBox. When changing the network interface, most probably the MAC address of the virtual network interface changed. The guest udev daemon uses the MAC address to assign a physical network interface to the same Linux network device. This is a known behavior and for VMware network devices there are exceptions defined in the udev rules.

comment:2 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to invalid
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use