VirtualBox

Ticket #456 (closed defect: invalid)

Opened 7 years ago

Last modified 6 years ago

CPU of host is going to 100% using XP as guest

Reported by: markba Owned by:
Priority: major Component: other
Version: VirtualBox 1.4.0 Keywords:
Cc: Guest type: other
Host type: other

Description

I'm using Ubuntu Feisty as host. After upgrading from 1.3.8 to 1.4.0, my XP session caused the host CPU to 100%. Before that, using 1.3.8, this combination (Feisty host, XP guest) was working perfectly. This situation is not workable for me, so I guess I'll downgrade to 1.3.8.

Other sessions like Ubuntu Feisty are working as expected.

Change History

comment:1 Changed 7 years ago by bradtem

I am also experiencing 100% utilization of one of my host's cores when VB is running with windows 2000 as a guest, on 1.4 with the 1.4 guest additions.

Was getting the same thing on 1.3.8 though, hoping 1.4 would fix it. Because of the two cores my host remains usable but I don't want to leave things this way. Usage actually _drops_ when the guest is doing things, presumably when it gets i/o bound etc.

comment:2 Changed 7 years ago by sandervl73

Did you enable USB in the guest? I recall that Windows 2000 doesn't power down the USB controller when it's not doing anything. That can cause a high cpu load.

Note that this doesn't apply to XP. Nevertheless you might want to disable USB to see if it makes any difference.

comment:3 Changed 7 years ago by markba

I did *not* enabled USB in the guest.

comment:4 Changed 7 years ago by markba

Tried the following with *no* effect:

  • upgraded Geust additions from 1.3.8 to 1.4.0
  • removed shared folders

comment:5 Changed 7 years ago by markba

Recently upgraded to 1.5. CPU of the host is not 100% anymore, but somewhere between 30-40%. This is much better, but not as good as 1.3.8, where it can drop to almost zero.

comment:6 Changed 7 years ago by markba

I figured it out. It was F-Prot, my anti-virus tool. I use AVG now, and CPU drops to (almost) zero.

As far as I'm concerned, you can close this bug, provided you don't want to investigate further, maybe for other users who cannot get rid of f-prot.

comment:7 Changed 6 years ago by Technologov

This looks like a duplicate of bug #824.

-Technologov

comment:8 Changed 6 years ago by michael

  • Status changed from new to closed
  • Resolution set to invalid

Closing as obsolete. Please reopen if it still applies to VirtualBox 1.5.6.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use