VirtualBox

Ticket #4545 (closed defect: fixed)

Opened 5 years ago

Last modified 15 months ago

Guest time goes too fast

Reported by: LoOoD Owned by:
Priority: critical Component: other
Version: VirtualBox 3.0.2 Keywords: time clock fast
Cc: Guest type: other
Host type: Mac OS X

Description (last modified by frank) (diff)

Host is a OSX, guest is a CentOS 5.3 with kernel 2.6.18-128.1.16. The time on the guest host is going too fast. For every hour, the guest adds an additional 40 minutes to the time.

Change History

comment:1 Changed 5 years ago by LoOoD

I'm doing the following in screen to keep the time synced for now.

while : ; do ntpdate 172.17.17.10 ; sleep 10; done

Its consistently 5 seconds faster.

comment:2 Changed 5 years ago by marvin0815

I can confirm this with Windows XP host and CentOS 4.7 (x86) guest. The time it gains differs from several minutes per second on heavy activity (like service starts) and some seconds when just typing in a ssh console.

And apparently this doesn't happen with CentOS 4.7 AMD64 guest.

comment:3 Changed 4 years ago by nicolas.dubois

Same problem here

Host: Quad core / Vista x64 Guest: Centos 5.3 x64 2.6.18-164.2.1

comment:4 Changed 4 years ago by finex

Isn't this a duplicate of bug  http://www.virtualbox.org/ticket/4453 ?

comment:5 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

This problem should be fixed with VBox 3.0.12. Probably you have to add the kernel parameter nmi_watchdog=0, otherwise the guest could crash with VBox 3.0.12. Please reopen if necessary.

comment:6 Changed 4 years ago by dcottingham

  • Status changed from closed to reopened
  • Resolution fixed deleted

Running 3.0.12 (r54655) on Ubuntu 9.04, with a Windows Vista guest.

Guest clock is persistently *slow* (i.e. ~20 minutes behind host clock).

On updating the guest's clock to the correct time, about half an hour later, the time is 17 minutes slow. This problem continues even after the reboot of the guest.

Host is Intel Core 2 quad core, 5319.92 bogomips.

Thoughts?

comment:7 Changed 4 years ago by helmo

Stopping the guest, and then starting it again has 'solved' such problems for me in the past. A simple reboot or save/start would have no effect in such cases.

I guess there is something in the guest's state that's gone wrong. In my case it often occurred just after a save/start cycle e.g. for a VirtualBox upgrade. (Linux host and guest)

comment:8 Changed 4 years ago by frank

  • Description modified (diff)
  • Summary changed from Guest host time goes too fast to Guest time goes too fast

comment:9 Changed 15 months ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed
  • Description modified (diff)

Please reopen if still relevant with VBox 4.2.6.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use