VirtualBox

Ticket #4538 (closed defect: obsolete)

Opened 5 years ago

Last modified 5 months ago

VM cannot focus by mouse (move or click) / SMP only -> fixed in 3.0.6

Reported by: xok Owned by:
Priority: major Component: VM control
Version: VirtualBox 3.0.2 Keywords:
Cc: Guest type: Windows
Host type: Windows

Description (last modified by frank) (diff)

Before version 3.0.2, I did not have this problem.

VM cannot focus by mouse, e.g, If I pass over the VM screen the screensaver is still activated.

Even if I click with the mouse on the black area, it does not do anything...

Although If set the focus and click on any key the VM is activated (screensaver goes away)

Sometime this behaviour happens in the Guest without the screensaver, e.g., cannot click with the mouse on the windows but if I do a ALT+TAB, everything starts to work properly.

Attachments

vbox_focus.GIF Download (42.8 KB) - added by xok 5 years ago.
VBOX Guest on the second screen (Dualhead)

Change History

Changed 5 years ago by xok

VBOX Guest on the second screen (Dualhead)

comment:1 Changed 5 years ago by xok

Made a regression to the VirtualBox 3.0.0 problems persists.

Further Notes:

The Guest randomly looses the focus, and cannot click on the VM until you press any key (e.g. CONTROL).

comment:2 Changed 5 years ago by xok

Made another regression to version 2.2.4 and everything stable now... :)

FYI, Hardware Information:

Notebook - ASUS M50SV HOST - Win XP SP3 Guest - Win 2003 R2 SP2

comment:3 Changed 5 years ago by mpaigni

Hello

Facing the same problem since upgrading to 3.0 I use an XP VM on top of an XP host.

Same behaviour as xok described. Sporadically but very annoying. I have not discovered any pattern first clicks work and then freeze... I might be wrong

It seems as if the mouse is not captured properly inside the VM windows and only the outer VM frame responds to it only by pressing the "ctrl-alt-del" menu item or by disabling and re-enabling the "Mouse Integration" things work out.

If I have the Mouse integration off it seems that the problem is bypassed.

regards Mike (great show in Athens - the t-shirt is great!)

comment:4 Changed 5 years ago by mpaigni

sorry but even with the "mouse integration" off the freezing happened once more

I pressed the tab on keyboard and worked me out of the freezing... could it be something with the keyboard and not with the mouse after all... I will try other buttons as well.

My keyboard is pretty clean with no sticky buttons (honestly)!!! ;-)

comment:5 Changed 5 years ago by mpaigni

spacebar works too...!!

comment:6 Changed 5 years ago by xok

Hello mpaigni,

Yes it is very annoying!...

You can do the following to test: Open Explorer.exe and then wait about 5 secs and then move around directories (left area) for about 10secs and you will lose the Focus in the VM!

Then you have to press any key (e.g. LEFT CONTROL, LEFT SHIFT, etc..) and once you press a key, you will gain Focus back! :)

I was forced to rollback to VirtualBox v2.2.4 because of this issue..

comment:7 Changed 5 years ago by xok

* You can do the following to test: Open Explorer.exe and then wait about 5 secs and then move around directories (left area) for about 10secs and you will lose the Focus in the VM!

NOTE: Move mouse cursor without clicking.

comment:8 Changed 5 years ago by quadcore

Hello, i have the same problem...

Im using a Windows XP Guest (Fullscreen) on a Linux Host, Virtualbox 3.0.2.
Sometimes you cant click anything, then if you click alt+tab it works again...

Very annoying while multitabling online poker... :D

comment:9 Changed 5 years ago by xok

This behaviour still persists in VirtualBox v3.0.4

"Sometimes you cant click anything, then if you click alt+tab it works again... Very annoying while multitabling online poker... :D "

Just press left CTRL or SHIFT and it works... Yes, it is very annoying... :)

comment:10 Changed 5 years ago by vkb201

Hello - I am seeing this as well with a WinXP SP3 guest running under RHEL5.3. The system has 12GB mem and 8 cores. I saw the issue under 3.02 and 3.04, but not under 2.24. The host is dual monitored and using Xinerama. Tab-alt works to unlock the mouse. I've tried appending 'force_async_tsc=1' to the modprobe line in /etc/init.d/vboxdrv with no luck.

comment:11 follow-up: ↓ 12 Changed 5 years ago by xok

ADDENDUM:

This behaviour is not happening with a VBOX Guest - Windows 2008 Server DataCenter SP1

comment:12 in reply to: ↑ 11 Changed 5 years ago by vkb201

Hi All - I did some further testing on a FC9 host and was able to replicate the behavior that I saw on my RHEL5.3 host under VirtualBox v.3.0.4. However, the behavior only appeared when my guest was running more than one CPU. The mouse worked correctly in this version with only one CPU configured for the guest WinXP SP3.

comment:13 Changed 5 years ago by xok

Hello vkb201,

You are right.

I did not notice that I was using 2 processors, after I change to 1 processor, the weird behaviour went away...

(I used the VM Guest this morning and it did not hanged!)

comment:14 Changed 5 years ago by sandervl73

That should be fixed in 3.0.6. You can try the beta to confirm ( http://forums.virtualbox.org/viewtopic.php?f=15&t=21919)

comment:15 Changed 5 years ago by sandervl73

  • Summary changed from VM cannot focus by mouse (move or click) to VM cannot focus by mouse (move or click) / SMP only -> fixed in 3.0.6

comment:16 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

comment:17 Changed 4 years ago by vkb201

  • Status changed from closed to reopened
  • Resolution fixed deleted

Hi All,

Though I no longer see this bug in my FC9 system running v.3.0.8 with a 2 proc WinXP guest, my RHEL5 box running 3.0.10 is still having problems. Any additional thoughts?

comment:18 Changed 4 years ago by Barron123

I've been dealing with this as well with a WinXP SP3 guest running under RHEL5.3. The system has 12GB mem and 8 cores. I saw the issue under 3.02 and 3.04, but not under 2.24. The host is dual monitored and using Xinerama. Tab-alt works to unlock the mouse. I've tried appending 'force_async_tsc=1' to the  norton 360 voucher line in /etc/init.d/vboxdrv with no good fortune.

comment:19 Changed 5 months ago by frank

  • Status changed from reopened to closed
  • Resolution set to obsolete
  • Description modified (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use