VirtualBox

Ticket #4527 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

BUG: unable to handle kernel NULL pointer dereference at 00000004

Reported by: ReD Owned by:
Priority: critical Component: network/hostif
Version: VirtualBox 3.0.2 Keywords:
Cc: Guest type: other
Host type: Linux

Description (last modified by frank) (diff)

On Fedora 11 Host, with kernel 2.6.29.5-191.fc11.i686.PAE, closing a Virtual machine often does the following to the kernel: (see the verbose text below)
After that, bad juju happens and the whole machine becomes unstable.

Jul 14 23:04:28 dave kernel: device eth0 entered promiscuous mode
Jul 14 23:15:11 dave kernel: device eth0 left promiscuous mode
Jul 14 23:15:14 dave kernel: BUG: unable to handle kernel NULL pointer dereference at 00000004
Jul 14 23:15:14 dave kernel: IP: [<c04213dc>] __ticket_spin_lock+0x8/0x19
Jul 14 23:15:14 dave kernel: *pdpt = 000000002f582001 *pde = 00000000431ab067 
Jul 14 23:15:14 dave kernel: Oops: 0002 [#1] SMP 
Jul 14 23:15:14 dave kernel: last sysfs file: /sys/devices/pci0000:00/0000:00:1f.1/host0/target0:0:1/0:0:1:0/block/sdb/sdb1/stat
Jul 14 23:15:14 dave kernel: Modules linked in: fuse vboxnetadp vboxnetflt vboxdrv nls_utf8 cifs vmnet vmblock vmci vmmon ipv6
kqemu dm_multipath uinput snd_intel8x0 snd_ac97_codec ac97_bus ppdev nvidia(P) snd_pcm parport_pc snd_timer snd i2c_i801 iTCO_wdt
floppy parport soundcore e100 mii sata_sil i2c_core iTCO_vendor_support snd_page_alloc ata_generic pata_acpi [last unloaded: microcode]
Jul 14 23:15:14 dave kernel:
Jul 14 23:15:14 dave kernel: Pid: 7, comm: events/0 Tainted: P           (2.6.29.5-191.fc11.i686.PAE #1)         
Jul 14 23:15:14 dave kernel: EIP: 0060:[<c04213dc>] EFLAGS: 00010202 CPU: 0
Jul 14 23:15:14 dave kernel: EIP is at __ticket_spin_lock+0x8/0x19
Jul 14 23:15:14 dave kernel: EAX: 00000004 EBX: ef0566c0 ECX: 00000246 EDX: 00000100
Jul 14 23:15:14 dave kernel: ESI: ef056610 EDI: ef0566bc EBP: f6a83f54 ESP: f6a83f54
Jul 14 23:15:14 dave kernel: DS: 007b ES: 007b FS: 00d8 GS: 0000 SS: 0068
Jul 14 23:15:14 dave kernel: Process events/0 (pid: 7, ti=f6a82000 task=f70ccbc0 task.ti=f6a82000)
Jul 14 23:15:14 dave kernel: Stack:
Jul 14 23:15:14 dave kernel: f6a83f5c c0716589 f6a83f64 f9fcf5fd f6a83f8c f9fcb1c8 00000000 f6a83f7c
Jul 14 23:15:14 dave kernel: 00000000 0000048f 00000000 ef0566c0 f6a6a580 ef0566bc f6a83fa8 c044392b
Jul 14 23:15:14 dave kernel: f6a6a584 f9fcb1a1 f6a6a580 f6a6a584 f6a6a58c f6a83fd0 c0443a70 00000000
Jul 14 23:15:14 dave kernel: Call Trace:
Jul 14 23:15:14 dave kernel: [<c0716589>] ? _spin_lock+0xd/0x10
Jul 14 23:15:14 dave kernel: [<f9fcf5fd>] ? RTSpinlockAcquire+0x13/0x15 [vboxnetflt]
Jul 14 23:15:14 dave kernel: [<f9fcb1c8>] ? vboxNetFltLinuxXmitTask+0x27/0x174 [vboxnetflt]
Jul 14 23:15:14 dave kernel: [<c044392b>] ? run_workqueue+0x8e/0x118
Jul 14 23:15:14 dave kernel: [<f9fcb1a1>] ? vboxNetFltLinuxXmitTask+0x0/0x174 [vboxnetflt]
Jul 14 23:15:14 dave kernel: [<c0443a70>] ? worker_thread+0xbb/0xc7
Jul 14 23:15:14 dave kernel: [<c0446b95>] ? autoremove_wake_function+0x0/0x34
Jul 14 23:15:14 dave kernel: [<c04439b5>] ? worker_thread+0x0/0xc7
Jul 14 23:15:14 dave kernel: [<c04468bc>] ? kthread+0x41/0x65
Jul 14 23:15:14 dave kernel: [<c044687b>] ? kthread+0x0/0x65
Jul 14 23:15:14 dave kernel: [<c0409dbf>] ? kernel_thread_helper+0x7/0x10
Jul 14 23:15:14 dave kernel: Code: 4f fd ff ff 5b eb 13 56 0f b7 d2 ff 75 08 89 d9 0f b6 c0 e8 6e fd
ff ff 5a 59 8d 65 f8 5b 5e 5d c3 90 90 55 ba 00 01 00 00 89 e5 <3e> 66 0f c1 10 38 f2 74 06 f3 90 8a 10 eb f6 5d c3 55 89 c2 89 
Jul 14 23:15:14 dave kernel: EIP: [<c04213dc>] __ticket_spin_lock+0x8/0x19 SS:ESP 0068:f6a83f54
Jul 14 23:15:14 dave kernel: ---[ end trace 1ef8487d0321cf6f ]---

Attachments

Vbox-session.log Download (84.7 KB) - added by ReD 5 years ago.
Virtualbox Log File
Kernel-log Download (3.1 KB) - added by ReD 5 years ago.
Kernel Log
diff_netfilter Download (1.4 KB) - added by frank 5 years ago.
netfilter diff

Change History

Changed 5 years ago by ReD

Virtualbox Log File

Changed 5 years ago by ReD

Kernel Log

comment:1 Changed 5 years ago by frank

  • Component changed from other to network/hostif

comment:2 Changed 5 years ago by frank

  • Description modified (diff)

Changed 5 years ago by frank

netfilter diff

comment:3 Changed 5 years ago by frank

ReD, I sounds to me that the problem is not that difficult to reproduce for you. So far we were not able to reproduce it locally but perhaps you could patch your netfilter host kernel driver with the patch I just attached. After patching, please recompile+reload the host kernel modules:

sudo su
cd /usr/src/vboxnetflt-3.0.2
patch -p0 < ~/diff_netfilter
/etc/init.d/vboxdrv setup

After that, please try to reproduce the kernel warning and attach the output of dmesg to this defect. Thank you!

comment:4 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if still relevant. VBox 3.0.8 was just released.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use