VirtualBox

Ticket #4524 (closed defect: duplicate)

Opened 5 years ago

Last modified 5 years ago

UDP Port forwarding broken in version 3.0.2

Reported by: Jo-W Owned by:
Priority: major Component: network/NAT
Version: VirtualBox 3.0.2 Keywords: UDP forwarding
Cc: Guest type: Linux
Host type: Windows

Description

I had VirtualBox 2.2.4r47978 running on Windows XP 32bit with xubuntu 9.04 as the guest (with additions).

With a few port forwardings:

VirtualBox Command Line Management Interface Version 2.2.4
(C) 2005-2009 Sun Microsystems, Inc.
All rights reserved.

Key: GUI/SaveMountedAtRuntime, Value: yes
Key: GUI/LastWindowPostion, Value: 132,73,720,444
Key: GUI/Fullscreen, Value: off
Key: GUI/Seamless, Value: off
Key: GUI/AutoresizeGuest, Value: on
Key: VBoxInternal/Devices/pcnet/0/LUN#0/Config/ASSS/Protocol, Value: TCP
Key: VBoxInternal/Devices/pcnet/0/LUN#0/Config/ASSS/GuestPort, Value: 5000
Key: VBoxInternal/Devices/pcnet/0/LUN#0/Config/ASSS/HostPort, Value: 5000
Key: VBoxInternal/Devices/pcnet/0/LUN#0/Config/ASSS2/Protocol, Value: TCP
Key: VBoxInternal/Devices/pcnet/0/LUN#0/Config/ASSS2/GuestPort, Value: 5001
Key: VBoxInternal/Devices/pcnet/0/LUN#0/Config/ASSS2/HostPort, Value: 5001
Key: VBoxInternal/Devices/pcnet/0/LUN#0/Config/ASSS_UDP/Protocol, Value: UDP
Key: VBoxInternal/Devices/pcnet/0/LUN#0/Config/ASSS_UDP/GuestPort, Value: 5000
Key: VBoxInternal/Devices/pcnet/0/LUN#0/Config/ASSS_UDP/HostPort, Value: 5000
Key: GUI/InfoDlgState, Value: 400,450,normal
Key: VBoxInternal/Devices/pcnet/0/LUN#0/Config/ASSS2_UDP/Protocol, Value: UDP
Key: VBoxInternal/Devices/pcnet/0/LUN#0/Config/ASSS2_UDP/GuestPort, Value: 5001
Key: VBoxInternal/Devices/pcnet/0/LUN#0/Config/ASSS2_UDP/HostPort, Value: 5001
Key: GUI/LastCloseAction, Value: shutdown
Key: GUI/MiniToolBarAutoHide, Value: on

In other words TCP & UDP forwarding on port 5000 and 5001

This worked fine for weeks, until I upgraded today to VirtualBox 3.0.2. I noticed that while the TCP forwarding worked, the UDP forwarding did not. (nothing has changed on the guest OS).

I then downgraded back again to VirtualBox 2.2.4 and the port forwarding is working properly again.

Change History

comment:1 Changed 5 years ago by frank

  • Component changed from other to network/NAT

comment:2 Changed 5 years ago by Hachiman

  • Status changed from new to closed
  • Resolution set to duplicate

duplicate of #4604

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use