VirtualBox

Ticket #4510 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

Guru Meditation while enabling networking in Windows Guests => Fixed in SVN

Reported by: sagarun Owned by:
Priority: major Component: network
Version: VirtualBox 3.0.4 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

I installed virtual box 3.02 today in my fedora 11 box. I tried to enable my disabled network connection (i disabled it few months ago) in control panel of windows xp professional (guest).Suddenly a window tilted "Virtual box -Guru Mediation" and said "A critical error has occurred while running the virtual machine and the machine execution has been stopped."

Attachments

VBox.log Download (262.2 KB) - added by sagarun 5 years ago.
Error log
VBox.jpg Download (44.0 KB) - added by sagarun 5 years ago.
npardoe_VBox.log Download (205.3 KB) - added by npardoe 5 years ago.
Additional test case dump - log file
npardoe_VBox.png Download (18.2 KB) - added by npardoe 5 years ago.
Additional test case dump - screenshot
npardoe2_VBox.log Download (210.7 KB) - added by npardoe 5 years ago.
Additional test case dump - log file (VirtualBox 2.2.4)
npardoe2_VBox.png Download (43.2 KB) - added by npardoe 5 years ago.
Additional test case dump - screenshot (VirtualBox 2.2.4)

Change History

Changed 5 years ago by sagarun

Error log

Changed 5 years ago by sagarun

comment:1 in reply to: ↑ description Changed 5 years ago by sagarun

Replying to sagarun:

VM crashes while enabling networking in Windows Hosts

oops , its not windows hosts, its windows guests!

comment:2 Changed 5 years ago by dburton

I have this issue as well. The setup is exactly the same, except I am running Ubuntu 9.04.

comment:3 follow-up: ↓ 4 Changed 5 years ago by Hachiman

  • Summary changed from VM crashes while enabling networking in Windows Hosts to guru meditation while enabling networking in Windows Hosts

comment:4 in reply to: ↑ 3 ; follow-up: ↓ 6 Changed 5 years ago by sagarun

Replying to Hachiman:

Please change the summary to: guru meditation while enabling networking in Windows Guests.

comment:5 Changed 5 years ago by Hachiman

  • Summary changed from guru meditation while enabling networking in Windows Hosts to guru meditation while enabling networking in Windows Guests

comment:6 in reply to: ↑ 4 Changed 5 years ago by Hachiman

Replying to sagarun:

Replying to Hachiman:

Please change the summary to: guru meditation while enabling networking in Windows Guests.

done.

comment:7 Changed 5 years ago by jgomez17

I am experiencing the same symptoms. Windows XP SP3 guest on Ubuntu 9.04. VirtualBox 3.0.2 r49928

comment:8 follow-up: ↓ 9 Changed 5 years ago by frank

Could you give a detailed list of instructions how to reproduce this? Plus a VBox.log file when this happened. Thank you!

comment:9 in reply to: ↑ 8 Changed 5 years ago by sagarun

Replying to frank:

Could you give a detailed list of instructions how to reproduce this? Plus a VBox.log file when this happened. Thank you!

I am afraid, the log file has been already uploaded as attachment!

To reproduce this, disable your network connection in control panel->Network Connections>rightclick->disable (if its not disabled already), Right click the disabled network and enable it!

comment:10 Changed 5 years ago by sagarun

The bug is still in virtualbox 3.0.4 , some one fix it please.

Changed 5 years ago by npardoe

Additional test case dump - log file

Changed 5 years ago by npardoe

Additional test case dump - screenshot

comment:11 Changed 5 years ago by npardoe

I can confirm I'm experiencing the same bug.

Host information - Linux dt19.im.local 2.6.27-14-generic #1 SMP Fri Jul 24 22:19:33 UTC 2009 i686 GNU/Linux [Ubuntu 8.10 (Intrepid Ibex)]

Guest information - Windows XP Professional (Service Pack 3)

VirtualBox information - VirtualBox 3.0.4 r506777 Installed direct from the VirtualBox apt repository.

I've attached the dump files (npardoe_VBox.log and npardoe_VBox.png) so there's more than one example to go off.

comment:12 Changed 5 years ago by npardoe

I tried rolling back to VirtualBox 2.2.4 r47978, uninstalling completely the VirtualBox 3 Guest Additions then clean installing the Guest Additions which ship with 2.2.4. The same issue occurs as indicated above (see log npardoe2_VBox.log and screenshot npardoe2_VBox.png).

I also tried uninstalling the Guest Additions then enabling the network adapter which *did work* and the network adapter was enabled. I tried this under VirtualBox 2.2.4 and 3.0.4 - both times *without* Guest Additions buth with the network adapter enabled. I was then free to reinstall Guest Additions in VirtualBox 2 or 3, however, with Guest Additions installed disabling then enabling the network adapter didn't reproduce the Guru Meditation error.

A workaround for this seems to be uninstalling Guest Additions, enabling the network adapter then reinstalling Guest Additions works fine in VirtualBox 2.2.4 or 3.0.4 and after reinstalling Guest Additions you are *NOT* able to enable/disable the network adapter. If you disable the network adapter, shut down the machine, then enable it the Guru Meditation issue comes back and the only fix is to uninstall Guest Additions then enable the network adapter. This looks like a Guest Additions driver issue.

Host information - Linux dt19.im.local 2.6.27-14-generic #1 SMP Fri Jul 24 22:19:33 UTC 2009 i686 GNU/Linux [Ubuntu 8.10 (Intrepid Ibex)]

Guest information - Windows XP Professional (Service Pack 3)

Changed 5 years ago by npardoe

Additional test case dump - log file (VirtualBox 2.2.4)

Changed 5 years ago by npardoe

Additional test case dump - screenshot (VirtualBox 2.2.4)

comment:13 Changed 5 years ago by frank

  • Version changed from VirtualBox 3.0.2 to VirtualBox 3.0.4
  • Summary changed from guru meditation while enabling networking in Windows Guests to Guru Meditation while enabling networking in Windows Guests => Fixed in SVN

Finally reproduced and fixed. The fix will be available with the next maintenance release.

comment:14 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use