VirtualBox

Ticket #451 (closed defect: fixed)

Opened 7 years ago

Last modified 4 years ago

winXP guest using 100% of one of CPU's

Reported by: dmontywilliams Owned by:
Priority: major Component: other
Version: VirtualBox 1.6.4 Keywords:
Cc: Guest type: other
Host type: other

Description

host - mandriva2007.1 x86-64 kernel 2.6.17.14 intel E6600 core 2 duo guest Windows XP SP2. Taskmanager reports process "svchost.exe" user "system" as using most of the cycles. There are more than one copies of svchost.exe running.

VirtualBox 1.4.0 amd64 binary downloaded from innotek.

Virtual machine created and formerly run with VirtualBox 1.3.8 OSE from mandriva 2007.1 x86-64 kernel 2.6.17.13

Attachments

VBox.log Download (35.0 KB) - added by dmontywilliams 7 years ago.
vbox.log
VBox.2.log Download (44.7 KB) - added by ariel 6 years ago.
vbox3.2.0-2010-06-16-17-09-37.log Download (39.1 KB) - added by codenamezero 4 years ago.
vbox3.2.0-2010-06-16-17-09-37.2.log Download (39.1 KB) - added by codenamezero 4 years ago.
vbox3.2.4-2010-06-16-17-12-46.log Download (39.6 KB) - added by codenamezero 4 years ago.

Change History

Changed 7 years ago by dmontywilliams

vbox.log

comment:1 Changed 7 years ago by markba

Having the same problem here, using Ubuntu Feisty as host. This problem came imminent after upgrading from 1.3.8 to 1.4.0. So before, using 1.3.8, this combination (Feisty host, XP guest) was working perfectly.

comment:2 Changed 7 years ago by markba

After rereading the problem text, I guess my problem is different: in my case, the host goes to 100% as the guest stays normal. Please ignore my comment.

comment:3 Changed 7 years ago by dmontywilliams

Added note: allocated base memory for VM is 512MB. Host monitor reports memory used by VirtualBox process is over 580MiB. CPU load is reasonable until a user is logged on in guest Windows XP. Logging user out does not drop CPU load, only closing VM drops load. Host monitor reports process using all the cycles is VirtualBox (one of two instances running).

comment:4 Changed 7 years ago by dmontywilliams

Problem resolved - sort of.

Using taskmanager to kill the incidence of svchost.exe which is using all the CPU cycles allows the frozen install process to continue. Had to do this each time to complete installation of guestadditions.iso, USB controller, and scanner software. CPU usage is now below 5% at idle.

Could someone explain to me what this is doing?

comment:5 Changed 6 years ago by Technologov

This looks like a duplicate of bug #824.

-Technologov

comment:6 Changed 6 years ago by ariel

I've been suffering this virtualbox issue for long.

Always in ubuntu hosts (7.10 32bits, and now 8.04 64bits), in different host machines (laptops and desktops), with clean-install WinXP SP2, now all patched to SP3.

All virtuabox releases up to today's 1.5.6. A royal pain.

Right after the guest boots, the CPU ussage of both host and guest shots up and stays in 100%. WinXP task manager shows that the svchost process is eating all available cpu. After I kill it, all returns to normal. Sometimes after a while svchost shots up again.

Any hint on how to solve this would be greatly appreciated.

comment:7 Changed 6 years ago by ariel

Typo: I meant: "Today's VB 1.6". Same problem shows up in virtual box 1.6 64bits. All the way up from 1.4 or so, 32bits.

comment:8 Changed 6 years ago by frank

ariel, please could you attach a VBox.log file you your WinXP session? And you observed this problem for all releases of VirtualBox you tested? Or was there an early 1.3.x release which did not show this behavior?

Changed 6 years ago by ariel

comment:9 Changed 6 years ago by ariel

Attached vbox.log

The problem in 1.4 and beyond. I seem to remember that Ii didn't have this problem in 1.3.

Today as usual I had to manually kill svchost because it was eating the cpu. Uncommonly, I needed to use audio output from the virtual machine and found that it was not working. I realized that audio is lost for the virtual machine when I kill the ill-behaved svchost.

Then I opened up vbox.log and found a bunch of messages regarding audio. Not sure if they show the problem or not, but still.

Now I am using pulseaudio output with vbox 1.6. But before (with 1.4.x and 1.5.x) I used alsa, and had exactly the same problem.

The host is Winxp (orignally SP2, now SP3, no improvements in this issue after installing sp3).

If I am very patient (20 minutes or so) svchost seems to eventually calm down and go back to normal (close 0 cpu %).

Hopefully this can be reproduced by others and can be fixed.

comment:10 Changed 6 years ago by ariel

Type: The GUEST is winxp (originally sp2, now sp3). The HOST is ubuntu 8.04/64bits. Previous hosts (7.04, 7.10, 32bits) had the same problem.

comment:11 Changed 6 years ago by ariel

Unfortunately, vbox 1.6.2 didn't improve things at all in this end.

comment:12 Changed 6 years ago by frank

  • Version changed from VirtualBox 1.4.0 to VirtualBox 1.6.2

ariel, could you try if disabling the USB controller for the guest improves the CPU load? And as second step, try to disable VT-x as well. Does this make any difference?

comment:13 Changed 6 years ago by steve

I am experiencing 100% usage of one core as well. Here is my setup:

Version: 1.6.2
Host: Ubuntu Hardy 64-bit running on Intel Core 2 Duo
Guest: Windows XP SP2 + Guest Extensions

Not using VT-x/AMD-V. Only hard disk (rawdisk to one of my partitions) and network adapter enabled. I would like to eventually use USB host devices but have not yet enabled the feature.

Strange and interesting observation: In the session information dialog->runtime it says Guest Additions: Version 1.4 but below that it says Guest OS Type: Not Detected

Ultimately windows reports idle CPU usage of 4-8% and VirtualBox task on host is 100%-102% at all times. I wouldn't complain except that it makes for a very hot laptop that discharges the battery very quickly.

I'm happy to run tests or provide additional information.

comment:14 follow-up: ↓ 17 Changed 6 years ago by ciriarte

Hi guys, I am experiencing 100% usage of one core as well. Here is my setup:

Version: 1.6.2 Host: Ubuntu Hardy 64-bit running on Intel Core 2 Duo Guest: Windows XP SP3 + Guest Extensions

VT-x/AMD-V:Disabled, Guest Additions: Version 1.4

As Steve, I'm getting "Guest OS Type:" Not Detected.

I do a lot of flash, and probably this might be related to #1350

I will be happy to provide testing as well.

comment:15 Changed 6 years ago by steve

I experience this at all times regardless of whether a browser is open. It is rare that I open a browser in this guest.

This seems to be a serious and fairly common problem.

comment:16 Changed 6 years ago by slhommed

VirtualBox 1.6.2 (Sun xVM VirtualBox) Host: Ubuntu Hardy 8.04 (2.6.24-19 amd64) Intel Dual Core

Guest: Windows XP SP2

After starting the Guest OS in the VM the CPU immediately goes to >100% and remains the entire time. Some brief periods (at startup mostly) of completely disk utilization as well.

comment:17 in reply to: ↑ 14 Changed 6 years ago by ciriarte

Replying to ciriarte:

Hi guys, I am experiencing 100% usage of one core as well. Here is my setup:

Version: 1.6.2 Host: Ubuntu Hardy 64-bit running on Intel Core 2 Duo Guest: Windows XP SP3 + Guest Extensions

VT-x/AMD-V:Disabled, Guest Additions: Version 1.4

As Steve, I'm getting "Guest OS Type:" Not Detected.

I do a lot of flash, and probably this might be related to #1350

I will be happy to provide testing as well.

I've been testing 1.6.4 for a while now. The problem is still there 100% CPU, the only improvement (related to this issue) I've seen is that now it does detect the guest OS type. I'll keep posting my findings.

comment:18 Changed 6 years ago by frank

Does the host utilization change when you change two VMs in parallel (both idle)?

comment:19 Changed 6 years ago by frank

  • Version changed from VirtualBox 1.6.2 to VirtualBox 1.6.4

comment:20 Changed 5 years ago by david.woodward

I'm having this problem also. I notice that if I stop and DISABLE the "Automatic Updates" service the problem seems to go away. This is hardly an acceptable solution.

VirtualBox = 2.1.0 (x86)

Host = Windows XP SP3 (x86) Guest = Windows XP SP3 with 512MB RAM and 128MB video memory

Audio = disabled 3D Acceleration = enabled 1 Network Card Configured as NAT SATA = enabled USB = enabled (but no devices are attached at this time) VT-x = disabled PAE/NX = disabled ACPI enabled IO ACPI enabled

(Is this really still an issue after TWO YEARS?)

comment:21 Changed 5 years ago by kevinrotz

I'm having the same issues. Specifically, svchost.exe is hogging up CPU cycles on the guest, forcing one of the cores on the host to 100%.

Setup: Virtualbox = 2.1.2 (x86_64) Host = Linux 2.6.28 (x86_64) Guest = Windows XP SP3 with 1 GB RAM and 12 MB video memory (I have 4 GB RAM on my system, so I don't think it's an issue with paging) Audio = ALSA 3D = Disabled ACPI = Enabled IO APIC = Disabled

It's a shame, because it otherwise runs just as nicely as VMWare :-\

comment:22 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if still reproducible with VBox 3.1.6. Attach a new VBox.log file of a 3.1.6 session in that case.

Changed 4 years ago by codenamezero

Changed 4 years ago by codenamezero

Changed 4 years ago by codenamezero

comment:23 Changed 4 years ago by codenamezero

  • Status changed from closed to reopened
  • Resolution fixed deleted

Looks like this problem has come back since 3.2.0 and 3.2.4 Running RHEL AS4 Update 4, Kernel 2.6.9-42.EL on x86_64 USB, serial port, shared folder, 2D/3D accleration, sound card, pretty much all useless stuff disabled.

I've attached 2 vbox.log:

  • vbox3.2.0-2010-06-16-17-09-37.log
  • vbox3.2.4-2010-06-16-17-12-46.log

System Information


Time of this report: 6/16/2010, 17:13:20

Operating System: Windows XP Professional (5.1, Build 2600) Service Pack 3 (2600.xpsp_sp3_gdr.080814-1236)

Language: English (Regional Setting: English)

System Manufacturer: Dell Inc.

System Model: OptiPlex 745

BIOS: Phoenix ROM BIOS PLUS Version 1.10 2.3.1

Processor: Intel(R) Core(TM)2 CPU 6300 @ 1.86GHz (2 CPUs)

Memory: 2038MB RAM

Page File: 2256MB used, 1676MB available

Windows Dir: C:\WINDOWS

DirectX Version: DirectX 9.0c (4.09.0000.0904)

DX Setup Parameters: Not found

DxDiag Version: 5.03.2600.5512 32bit Unicode

comment:24 Changed 4 years ago by sandervl73

  • Status changed from reopened to closed
  • Resolution set to fixed

You misread the original report: Windows XP *guest* not host. You are running a Linux guest with a 1000 hz timer. You need to recompile the kernel with a lower timer frequency or use a grub divider option. (google is your friend for the details)

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use