VirtualBox

Ticket #4509 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

CentOS 5.3 + Xen reboots the Host -> fixed in SVN/3.0.4

Reported by: laga Owned by:
Priority: critical Component: other
Version: VirtualBox 3.0.2 Keywords:
Cc: Guest type: other
Host type: other

Description

Hello!

I've recently installed CentOS 5.3 and choose to install virtualisation support during their setup. This adds the Xen hypervisor as the default kernel.

If I have VT-x enabled:

  • the guest will hang at boot with a blinking cursor

If I have VT-X disabled:

  • the guest will load the Xen kernel, then reboot. The Xen kernel will load again and then the *host* will reboot.

Guest setup:

  • Vanilla CentOS 5.3 install with Xen enabled.

How to reproduce:

  • Download CentOS 5.3 i386 DVD iso
  • Set up VM, enable PAE, disable VT-x.
  • Boot and install CentOS. Select Virtualisation support during setup.
  • Reboot after install. The only available entry in the boot loader will be the Xen hypervisor.
  • Watch your box reboot

I'd love to attach a log file, but with the host rebooting, they end up empty.

My CPU: cpu family : 6 model : 15 model name : Intel(R) Core(TM)2 CPU 6300 @ 1.86GHz stepping : 6

Regards,

Michael

Change History

comment:1 Changed 5 years ago by michaelbn

Same here with: Intel(R) Core(TM)2 Quad CPU Q9400 @ 2.66GHz

comment:2 Changed 5 years ago by sandervl73

  • Priority changed from major to critical

comment:3 Changed 5 years ago by sandervl73

  • Summary changed from CentOS 5.3 + Xen reboots the Host to CentOS 5.3 + Xen reboots the Host -> fixed in SVN/3.0.4

Thanks for the report. Fixed in SVN/3.0.4

comment:4 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use