VirtualBox

Ticket #4506 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

Mouse not followed by GUI elements in guest -> fixed in SVN/upcoming version 3.0.6.

Reported by: CaptainFlint Owned by:
Priority: major Component: guest additions
Version: VirtualBox 3.0.2 Keywords:
Cc: Guest type: Linux
Host type: other

Description

I upgraded VB 2.2.4 to 3.0.2. After I updated Guest Additions in my openSUSE VM, the mouse pointer is no longer detected by the GUI elements. For example, when I move the mouse over tabs, buttons, desktop icons, they do not get highlighted. Besides, the mouse pointer shape remains unchanged: if it was a normal "arrow" pointer, it remains so even over the text edit fields, over hyperlinks, over window borders, etc. Only when I perform a click, it is detected, the click works (i.e. the button is pressed), and only then the mouse pointer takes the correct shape — and now this new shape becomes "sticked" and remains so until I click anywhere else.

I tried Guest Additions 3.0.0, and there was the same problem. Then I installed GA 2.2.4, and the mouse worked fine. Also I tried installing GA 3.0.2 and replacing only the vboxmouse driver with the one from 2.2.4, and this combination worked fine either. So, probably, there's something broken with the mouse driver in guest additions since 3.0.0.

Host OS: WinXP SP3 Pro
Guest OS: openSUSE 11.1, KDE 4.2.95 (4.3 RC1), X server 1.5.2

Attachments

VBox-3.0.2.log Download (51.9 KB) - added by CaptainFlint 5 years ago.
Log file of VM when mouse driver from GA 3.0.2 is loaded
VBox-2.2.4.log Download (51.8 KB) - added by CaptainFlint 5 years ago.
Log file of VM when mouse driver from GA 2.2.4 is loaded

Change History

Changed 5 years ago by CaptainFlint

Log file of VM when mouse driver from GA 3.0.2 is loaded

Changed 5 years ago by CaptainFlint

Log file of VM when mouse driver from GA 2.2.4 is loaded

comment:1 Changed 5 years ago by Aphax

I'm experiencing the same issue with a Gentoo host and guest, running the OSE version. Only way I could get the mouse to work normally again was downgrading the guest additions to 2.2.4. It seems as though with 3.0.2 the guest simply doesn't get any motion events until I actually click the mouse button.

comment:2 follow-up: ↓ 3 Changed 5 years ago by michael

Aphax: since you are using Gentoo, I will assume that you know how the details of your system setup :) Questions follow.

1) Did you get your Additions from Portage? 2) Did you set up xorg.conf on the guest yourself after you installed the Additions? 3) Which version of X.Org is your guest using? 4) Is your guest X.Org configured to use hal for input device autodetection?

The background is that as of X.Org version 1.5 (on the guest), our mouse driver handling changed a bit. We assume that the standard mouse driver is also loaded (normally in X.Org 1.5 and later, the "evdev" driver is autoloaded by hal. This does not hold true on openSUSE 11.1, and may not on Gentoo) and that the standard mouse driver handles mouse click events. vboxmouse only handles the pointer position and it should be associated with the /dev/vboxadd device, not /dev/mouse or whatever.

comment:3 in reply to: ↑ 2 Changed 5 years ago by Aphax

Hi Michael, I've managed to solve the problem now thanks to your background explanation; turns out I still had a section for the vboxmouse, and had disabled automatically adding devices in my xorg.conf, which I had created from scratch a long time ago for VirtualBox < 3. After removing all the input device sections everything is now dealt with by HAL like you hinted and it everything 'just works' :)

comment:4 Changed 5 years ago by michael

  • Summary changed from Mouse not followed by GUI elements in guest to Mouse not followed by GUI elements in guest -> fixed in SVN/upcoming version 3.0.6.

Fixed in SVN/upcoming version 3.0.6.

comment:5 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

comment:6 Changed 4 years ago by Barron123

do not realy know if this breaks something and I suspect this error to occur on every newer 64 Bit distribution (it fails with same symptom and error code on Ubuntu 8.10).

I tried to reproduce this error with opensuse 11.0 32 Bit but there aren't any RTSpinlock*  gotomypc Symbols exported - maybe they also shouldn't be exported on 64 Bit?

Environment: Host: opensuse 11.0 64 Bit Guest: opensuse 11.0 64 Bit or Ubuntu 8.10 64 Bit

comment:7 in reply to: ↑ description ; follow-up: ↓ 8 Changed 4 years ago by lantolin

Just in case it is useful for anyone. I had exactly the same problem. And commenting out the mouse section in my xorg.conf fixed it.

Setup:

host: Debian 5.0.3 lenny, all configs pretty standard guest: Debian squeeze, packages up-to-date as today

VirtualBox 3.1.2, mouse was working properly, but I needed to update due to a freeze when using shared folders.

VirtualBox 3.1.4, problem with the mouse, the one described in this ticket, and some others, problems while dragging, impossible to mark text by dragging, etc.

My xorg mouse section was:

Section "InputDevice"

Identifier "Configured Mouse"

Driver "vboxmouse" Option "CorePointer"

Option "Device" "/dev/input/mice" Option "Protocol" "ImPS/2" Option "ZAxisMapping" "4 5"

EndSection

Commenting it worked like a charm.

comment:8 in reply to: ↑ 7 Changed 4 years ago by lantolin

Correcting myself.

I did not notice at first, but with that change the problem was gone, but also the mouse integration.

Solved now.

I completely emptied the file, as some posts recommend. That didn't work, video driver was autodetected but mouse driver did not.

So, final working solution with video and mouse drivers is an /etc/X11/xorg.conf file with just this:

Section "InputDevice"
    Identifier	"Configured Mouse"
    Driver      "vboxmouse"
    Option      "CorePointer"
EndSection

The mouse section that was not working before (just in case is useful for anyone), was:

Section "InputDevice"
    Identifier	"Configured Mouse"
    Driver      "vboxmouse"
    Option      "CorePointer"
    Option		"Device"		"/dev/input/mice"
    Option		"Protocol"		"ImPS/2"
    Option		"ZAxisMapping"		"4 5"
EndSection
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use