VirtualBox

Ticket #4480 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

XP x64 guest (on XP x64 host) fails if more than 1 virtual CPU enabled -> retry with 3.1.4

Reported by: Kurt_Aust Owned by:
Priority: major Component: guest smp
Version: VirtualBox 3.0.4 Keywords: CPU
Cc: Guest type: Windows
Host type: Windows

Description

Exact same install media with exact same VM settings except:

If only one virtual processor is enabled the system installs and (as far as I can tell) runs flawlessly.

If two virtual processors are enabled the system still installs up to the second reboot (after the GUI install section).

However after that the system either simply fails to start (the white progress bar freezes or just a blank screen) or crashes with seemingly random BSODs (the one I remember was System Service Exception).

Attachments

VBox.log Download (88.3 KB) - added by Kurt_Aust 5 years ago.
VBox.log.3 Download (64.1 KB) - added by Kurt_Aust 5 years ago.
VBox314-2CPU.log Download (66.6 KB) - added by Kurt_Aust 4 years ago.

Change History

Changed 5 years ago by Kurt_Aust

Changed 5 years ago by Kurt_Aust

comment:1 Changed 5 years ago by Kurt_Aust

It would appear that the problem is not restricted to XP x64 guests.

The same problem is apparent with Windows 2000 guests.

comment:2 Changed 5 years ago by chooseopen

I see random BSODs with a Windows Server 2008 x64 guest running on a Windows Server 2008 x64 host when virtual CPUs are set to "2". Setting to "1" makes the BSODs disappear.

comment:3 Changed 5 years ago by Kurt_Aust

Problem remains with version 3.0.4

comment:4 Changed 5 years ago by frank

  • Version changed from VirtualBox 3.0.2 to VirtualBox 3.0.4
  • Component changed from other to VMM

comment:5 Changed 5 years ago by stevensm

Same problem with Windows 7 64 Bit and windows guests (XP, 2003, 2008, Windows 7) with more than 1 vCPU. During the installation of the windows guest there are random BSODs.

comment:6 in reply to: ↑ description Changed 5 years ago by Gibraltar

Also experiencing this problem (host Win7 Ultimare RTM x64 and guest Win SBS 2008). Didn't try to limit to only one CPU (will try at home), but did try disabling the network config - no more BSOD, but also no network (kinda defeats the purpose of installing a Windows Server :)

comment:7 Changed 5 years ago by Gibraltar

I've just confirmed that the same VM (Windows SBS 2008) is now stable with only one core enabled. Seems to be a problem related - 64bit host and SMP, hope it gets fixed soon :)

comment:8 Changed 5 years ago by Smeikkie

I'm having kind of the same problem. My host OS is Windows 7 x64 and the guest OS is windows server 2008 R2 x64.

When I assign two cpu to the virtual is sometimes hangs (Screen goes completly black. When I look in the task manager virtualbox is using 100% of the cpu) when I try to install something like SQL Server 2008. When using 1 cpu everything goes fine.

Is this something that can be fixed?

comment:9 Changed 5 years ago by Gibraltar

Possible solution - new test build available:  http://www.virtualbox.org/ticket/4947

Will test tonight and post results when done, fingers crossed ;)

comment:10 Changed 5 years ago by Gibraltar

Sorry to report the test build didn't help with my problem. So reverted to using only one core. Will keep waiting for a version that works with my setup :)

comment:11 Changed 5 years ago by sandervl73

  • Component changed from VMM to guest smp

comment:12 Changed 5 years ago by bboaz

I'm also having this problem; host is Vista x64, guest is Windows7 x64. Please fix as soon as possible. Thanks.

comment:13 Changed 5 years ago by blakeb

I am experiencing the same issue Win7RTM x64 host Server 2008 x64 guest. Mine works fine for a short time, and then VirtualBox.exe on the host goes up to 99% cpu usage and the vm is black. This is a feature of virtualbox that sets it apart from other virtualization, and it would be great if it could be fixed.

comment:14 Changed 5 years ago by blakeb

This is in 3.0.8 as well.

comment:15 Changed 4 years ago by Kurt_Aust

It would seem that version 3.0.10 has licked this problem, at least for me.

comment:16 Changed 4 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

Thanks for the feedback.

comment:17 Changed 4 years ago by Smeikkie

  • Status changed from closed to reopened
  • Resolution fixed deleted

I also thought it was fixed but when I tryed to install the Visual Studio Beta 2010 on my virtual of Windows Server 2008 R2 the screen went black again :s (2 cpu's enabled).

Can I provide you guys with information so that the ticket can be fixed?

comment:18 Changed 4 years ago by Technologov

Since Windows XP x64 and Windows Server 2003 x64 are based on the same kernel (NT 5.2), this bug may be related bug #5385

-Technologov

comment:19 Changed 4 years ago by sandervl73

  • Summary changed from XP x64 guest (on XP x64 host) fails if more than 1 virtual CPU enabled to XP x64 guest (on XP x64 host) fails if more than 1 virtual CPU enabled -> retry with 3.1.4

Retry with 3.1.4. That version will include an important stability fix for SMP guests.

comment:20 Changed 4 years ago by sandervl73

Please check if 3.1.4 beta 1 solves the problem:  http://forums.virtualbox.org/viewtopic.php?f=15&t=27300

comment:21 Changed 4 years ago by sandervl73

  • Status changed from reopened to closed
  • Resolution set to fixed

Please reopen if it still occurs with 3.1.4.

Changed 4 years ago by Kurt_Aust

comment:22 Changed 4 years ago by Kurt_Aust

  • Status changed from closed to reopened
  • Resolution fixed deleted

Same old problem with version 3.1.4, log attached, reverting to 3.0.12

comment:23 Changed 4 years ago by Kurt_Aust

3.1.6 appears to have fixed the problem (touch wood).

comment:24 Changed 4 years ago by sandervl73

  • Status changed from reopened to closed
  • Resolution set to fixed

Thanks for the feedback.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use