VirtualBox

Ticket #4401 (closed defect: duplicate)

Opened 5 years ago

Last modified 5 years ago

Windows XP guest hangs on exit

Reported by: Matoridi Owned by:
Priority: major Component: other
Version: VirtualBox 3.0.0 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

I've got a strange problem :

The Windows XP guest on my wife's computer cannot exit. When I try this, it starts closing but hang there indefinitely.

I tried closing it though the normal way and then by sending the close signal from VirtualBox.

The computer is a HP DV3 laptop with an ATI HD 3200 card (more on that below), and runs on Ubuntu 9.04. Processor is an AMD Turion X2.

The funny thing is, I tried her guest "hard disk" on my HP laptop which has almost the same specs except the video card (it's an Nvidia in this case), and everything works fine there.

Also, I've just tried again on her computer, and while XP was stuck in exiting, I switched to full screen : it closed XP, but not properly, the state of the guest remaining "Aborted"

I'm begining to thing this has something to do with the video card.

Can you help me?

Attachments

VBox.log Download (103.2 KB) - added by Matoridi 5 years ago.

Change History

Changed 5 years ago by Matoridi

comment:1 Changed 5 years ago by frank

Hmm, according to your log, the PulseAudio daemon could have some problems. Could you check if the guest still hangs if you run the VM with disabled sound (disable audio in the VM settings)?

comment:2 Changed 5 years ago by Matoridi

Thanks for the fast answer!

Windows XP exits normally if I disable the virtual sound card. I also tried a different host sound pilot (alsa), and as soon as try playing a sound, the guest crashed.

Using OSS as driver works, though. But I guess I should stick to disabling sound (otherwise Windows and Ubuntu won't be able to share the sound card).

comment:3 Changed 5 years ago by mooninite

Adding a "me, too" since I don't see an option to just add me to the CC list. OT: Bugzilla is a great bug tracking alternative.

comment:4 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #3100. The next release of VirtualBox will fix this hang, even with PulseAudio enabled. However, the connection terminated problem should be resolved by updating the pulseaudio server/libs on your host.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use