VirtualBox

Ticket #4400 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

virtual box hangs on holding down a cursor key

Reported by: neilclarkson Owned by:
Priority: critical Component: other
Version: VirtualBox 3.0.0 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description

I have Virtual Box 3.0 hosted on Ubuntu 9.04 (but I saw the same problem with the previous Virtual Box release). I have a VM with Ubuntu 8.04. If I have a large txt file loaded into gvim on the guest OS and I try to scroll down a couple pages by holding down the down arrow key, Virtual Box just hangs on me completely. Everytime. 100% reproducible so far.

Left the component field alone - didnt understand half the options in it.

Attachments

VBox.log Download (35.5 KB) - added by neilclarkson 5 years ago.
log from hanging virtual machine

Change History

comment:1 Changed 5 years ago by frank

Please attach a VBox.log file of such a hanging session.

Changed 5 years ago by neilclarkson

log from hanging virtual machine

comment:2 Changed 5 years ago by neilclarkson

Log duly attached, though I think it doesnt show anything interesting. The last line is less than 2 mins into the runtime of the machine and the hang was about 22 hours into the runtime of the machine.

I think I should elaborate on the "hang" though, because on further reflection I'm not sure "hang" is really the right word to describe it.

I hold down the down arrow for a few seconds, perhaps 5, so to scroll down the text file, and what I notice is that when I release the key, the editor carries on scrolling down the file. Thats not necessarily a bug in itself of course, it could be processing a few queued up key presses, but it keeps going until it hits the end of the file, and infact still keeps going even after that because the gvim window then starts rapidly flashing at me, which is consistent with it receiving more attempts to scroll down despite being at the end of the file. I've watched it do that for a couple of minutes and concluded that its just locked up doing that forever. I cant close out the gvim window, or indeed do anything else inside the VM window. The menu bar of the VM is also unresponsive. The main VM control window is unresponsive - the only thing I can do is force quit the whole of VirtualBox.

I guess its not really a "hang" because the VM is still providing some functionality - clearly trying to scroll down the file still and flashing the window - but clearly its locked up.

comment:3 Changed 5 years ago by neilclarkson

A few numbers. Go to the end of the text file, then hold down the down arrow for about 5 secs. gvim starts flashing, and its still flashing at me 5 mins later when I get bored of watching it.

comment:4 Changed 5 years ago by frank

Any change with VBox 3.0.6?

comment:5 Changed 5 years ago by neilclarkson

Yes, actually. I just tried (I've been avoiding holding down the cursor keys while editing) and its not reproducing. No lock up, and infact, the editor stops scrolling as soon as a I take my finger off the cursor. Excellent!

comment:6 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Thanks for the feedback!

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use