VirtualBox

Ticket #4399 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

OpenSolaris additions break GL -> Fixed in SVN.

Reported by: bqbauer Owned by:
Priority: major Component: guest additions
Version: VirtualBox 3.0.0 Keywords:
Cc: Guest type: Solaris
Host type: Solaris

Description

This may be related to ticket 4365.

With VB 3.0.0, tested on both Windows XP 32-bit host and an OpenSolaris 2009.06 64-bit host, certain applications like gnome-appearance-properties don't work. They report the following:

ld.so.1: gnome-appearance-properties: fatal: relocation error: file /usr/X11/lib/libGL.so: symbol glXFreeMemoryMESA: referenced symbol not found

ld.so.1: gnome-appearance-properties: fatal: relocation error: file /usr/bin/gnome-appearance-properties: symbol glXQueryServerString: referenced symbol not found

Additionally, with a 2009.06 guest, you cannot see windows move when they are dragged with the mouse, but once you let go of the mouse the window pops to the new location. If you click on the Gnome menus, there is no menu highlighting of what the mouse is hovering over. With a 2008.11 guest, these two issues do not manifest. Also, with v117 guests, the additions appear not to function at all. v117 is far less important than fixing these other issues.

I believe I have selected the correct version of the log files. If necessary, I can reproduce the problems again. This second part of my report renders OpenSolaris guests somewhat frustrating to use.

Attachments

VBox_2008.11.log Download (82.2 KB) - added by bqbauer 5 years ago.
VBox_2009.06.log Download (67.8 KB) - added by bqbauer 5 years ago.

Change History

Changed 5 years ago by bqbauer

Changed 5 years ago by bqbauer

comment:1 Changed 5 years ago by bqbauer

The 2009.06 log is from a freshly installed guest just to confirm this problem.

comment:2 Changed 5 years ago by ramshankar

The mouse issue has been fixed internally and would be part of the next available release. We're looking into the OpenGL issue, thanks for the report.

comment:3 Changed 5 years ago by leonid

  • Summary changed from OpenSolaris additions break GL to OpenSolaris additions break GL -> Fixed in SVN.

Fixed opengl linking issue, thanks for the report.

comment:4 Changed 5 years ago by bqbauer

Is the problem with menu highlighting and window movement related to the GL issues, since it only happens on 2009.06 guests, but not 2008.11? Or are these instead related to 4365? As long as all of these are addressed, because all make the guests very difficult to use.

comment:5 Changed 5 years ago by ramshankar

The mouse issue is not related to OpenGL. It's because of Xorg differences in the guest so #4365 is the same issue.

comment:6 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use