VirtualBox

Ticket #4396 (closed defect: duplicate)

Opened 5 years ago

Last modified 4 years ago

Failed to execute 'VBoxNetAdpCtl add' (exit status: 768) => vboxnetadp not installed

Reported by: skyman Owned by:
Priority: major Component: network/hostif
Version: VirtualBox 3.0.0 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

I'm runing ubuntu 9.04, VB r49315, when i trying to add virtual host network it fails with message:

Failed to execute 'VBoxNetAdpCtl add' (exit status: 768)..

Result Code: NS_ERROR_FAILURE (0x80004005) Component: HostNetworkInterface Interface: IHostNetworkInterface {ce6fae58-7642-4102-b5db-c9005c2320a8}

I'm made a search on this in forum, for a hours but didn't find a sollution on it. Please, reply as soon as possible, this is a very importand for me this time. (i'm sorry for this hurry)

P.S. Thanks for a great product and support!!

Change History

comment:1 Changed 5 years ago by skyman

I find a sollution, please update message/error information and faq about this problem

 http://forums.virtualbox.org/viewtopic.php?f=7&t=17315&p=84533#p84533

Thanks a lot!

comment:2 Changed 5 years ago by frank

Before adding anything to our FAQ we would like to understand what went wrong with your installation. And DKMS is already mentioned in the documentation. I assume you installed the Jaunty package from our website. The question is why the module was apparently not properly installed during the first time you installed VirtualBox.

comment:3 Changed 5 years ago by skyman

All I can say, - no error messages went on first installation and there can be a better way to inform user about same error (kernel modules not loaded). I spent much time to find way out.

In any case, thanks a lot, great product.

comment:4 Changed 5 years ago by frank

  • Summary changed from Failed to execute 'VBoxNetAdpCtl add' (exit status: 768).. to Failed to execute 'VBoxNetAdpCtl add' (exit status: 768) => vboxnetadp not installed

comment:5 Changed 5 years ago by frank

  • Priority changed from critical to major

comment:6 Changed 4 years ago by icanfly

#service vboxdrv setup This helped me. Kernel modules was removed, rebuilded and reloaded.

comment:7 follow-up: ↓ 12 Changed 4 years ago by nikbox

I have just upgraded Ubuntu netbook remix 9.10 to 10.4 (and VirtualBox OSE seemed to be updated to the last 3.1.6). After that my VMs didn't run. And the host-only interface (vboxnet0) disappeared and failed to be created with the error: "Failed to execute 'VBoxNetAdpCtl add' (exit status: 768)".

The only worked out solution I found at  http://fedoraforum.org/forum/showthread.php?p=1332225: After this command VB started with the host interface appeared.

sudo insmod /lib/modules/2.6.31-21-generic/updates/dkms/vboxnetadp.ko

comment:8 Changed 4 years ago by mkalen

Same problem after upgrade of Kubuntu 9.10 to 10.4. Using VirtualBox DEBs from  http://download.virtualbox.org/virtualbox/debian and have 3.1.6 r 59338 installed.

vboxnetflt and vboxnetadp modules did not load because of missing symbols, similar to bug #5817

The following command solved the problem:

sudo /etc/init.d/vboxdrv setup

I had no idea that DKMS compilation failed during O/S upgrade and only found out after searching online for the error message issued at VM startup failure: "Failed to execute 'VBoxNetAdpCtl add' (exit status: 768)". The information in this bug helped in finally tracking down the problem in vboxnetadp.

I agree with skyman that it would be helpful if error messages about e.g. missing host-only networks would contain a hint that this might be due to a missing vboxnetadp module in the running kernel. Even better would be if VirtualBox could detect presence of the required kernel modules at startup and issue warnings if not found.

comment:9 Changed 4 years ago by mkalen

For the record, this now seems to happen after every kernel upgrade. Just got Linux 2.6.32-22-generic kernel through Ubuntu 10.04 LTS upgrades and DKMS seems to have failed to compile the VirtualBox modules again (except for vboxdrv which works out of the box).

Again, this command fixes the problem with vboxnetadp:

sudo /etc/init.d/vboxdrv setup

Is there any chance of getting a VirtualBox package for lucid (Ubuntu 10.04 LTS) where the correct DKMS compile order is ensured?

comment:10 Changed 4 years ago by frank

Tell me how one can ensure the correct DKMS order and we will fix it.

comment:11 Changed 4 years ago by mkalen

I have initiated contact with the Debian DKMS maintainers and will try to get some help from there. I still suggest you add some info about "possible missing vboxnetadp kernel module" in the errors mentioned in this bug.

Regarding the underlying DKMS problem, I will add furher info (if I get some response from the DKMS team) in bug #5817, since 5817 better describes what goes wrong. This bug is a consequence/symptom of 5817.

comment:12 in reply to: ↑ 7 Changed 4 years ago by nikbox

Replying to nikbox:

I have just upgraded Ubuntu netbook remix 9.10 to 10.4 (and VirtualBox OSE seemed to be updated to the last 3.1.6). After that my VMs didn't run. And the host-only interface (vboxnet0) disappeared and failed to be created with the error: "Failed to execute 'VBoxNetAdpCtl add' (exit status: 768)".

I've totally fixed it by removing every VirtualBox related package, cleaning 'tails' with 'Janitor' and installing VB again.

comment:13 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

This is actually a duplicate of #5817 and should be finally fixed in the upcoming 3.2.10 release.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use