VirtualBox

Ticket #4377 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

guest hangs on IO operations

Reported by: costing Owned by:
Priority: major Component: other
Version: VirtualBox 3.0.0 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description

I cannot reproduce the problem but it seems to be related to IO, most probably network. At some point after a few hours of working the guest hangs almost completely. It still answers to ping for example and if I have a console opened I can still type a few commands. But once something requires some IO, it hangs. For example, direct login on tty accepts u/p then says: "Login timed out after 60 seconds". I managed only to see the list of processes in D (hundreds of them) and for example strace on an httpd instance shows it blocked in accept(...

There is nothing in dmesg on either the guest or the host. VBox.log is also clean. This exact configuration worked fine until ver 3.0.0, so it looks like a bug in the latest version. Apparently it doesn't depend on any hardware virtualization features since it showed even in 2 CPUs with all the options enabled and 1 CPU with none of the options.

I'll try downgrading to 2.2.4 to see if it solves the problems, but it might take a while until I can be sure of the outcome.

Attachments

VBox.log Download (40.1 KB) - added by costing 5 years ago.

Change History

Changed 5 years ago by costing

comment:1 Changed 5 years ago by Nephom

What driver version of Intel NIC card?

comment:2 Changed 5 years ago by costing

# modinfo e1000 filename: /lib/modules/2.6.29.5/kernel/drivers/net/e1000/e1000.ko parmtype: copybreak:uint parm: copybreak:Maximum size of packet that is copied to a new buffer on receive author: Intel Corporation, <linux.nics@…> description: Intel(R) PRO/1000 Network Driver license: GPL version: 7.3.21-k3-NAPI

comment:3 Changed 5 years ago by costing

Just checked and one of the guests is again hanged even running under 2.2.4. And it didn't hang while wget-ing an Ubuntu image, scp-ing it to another guest etc (each at 5-6MB/sec), but some time after.

comment:4 Changed 5 years ago by Nephom

I don't know this issue which caused by  http://sourceforge.net/tracker/index.php?func=detail&aid=2208656&group_id=42302&atid=447451, so I change to AMD PCnetIII but the system hang after network transmitted(disk IO error). When I disable IO APIC, the system seems like stable.

comment:5 Changed 5 years ago by Nephom

BTW,If you have checked any network adpaters with IO APIC function, the system will sometimes show dma_timer_expiry error message on booting OS(or ncq failed). I found this issue in 2.2.4.

comment:6 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

VBox 3.0.2 should fix that problem. If you still see the dma_timer_expiry error message, please open a separate defect.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use