VirtualBox

Ticket #4373 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

Opaque (i.e. unusable display) when using VB 3.0.0 r49315 on X11 radeonhd

Reported by: aanno Owned by:
Priority: major Component: other
Version: VirtualBox 3.0.0 Keywords:
Cc: Guest type: other
Host type: other

Description

When trying to use VB 3.0.0 r49315 on my (K)unbuntu 9.04 (jaunty) x86_64 (aka amd64) system, I hardly see anything because most of the guest OS (e.g. Windows XP) is opaque. Net result is that VB is unsuable with radeonhd X11 driver (with enabled DRI, 3d support, accelerated).

In contrast, if I'm using the radeon X11 driver (without DRI (?), no 3d support, but accelerated), the display looks all right. In this case, it is no problem to use the VB guest OS.

I trying to add some screenshots of this...

Change History

comment:1 Changed 5 years ago by michael

Did you mean to say transparent rather than opaque? If so this is probably a duplicate of #3095, and the workaround there (starting VBox as

export XLIB_SKIP_ARGB_VISUALS=1
VirtualBox

should help.

comment:2 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

There is a better fix in VBox 3.0.2.

comment:3 Changed 5 years ago by frank

(Actually this is a workaround for Qt/X11)

comment:4 Changed 5 years ago by michael

If you are interested in helping us on this, you might also want to give this test build (disclaimer  here) a try

 http://www.virtualbox.org/download/testcase/VirtualBox-2009-07-30-22-14-17-lin64-3.0-3.0.3-r50558.run

since we made changes to the fix and would like feedback that it still works for everyone.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use