VirtualBox

Ticket #4312 (closed defect: invalid)

Opened 5 years ago

Last modified 4 years ago

cannot discard current snapshot

Reported by: tkalfaoglu Owned by:
Priority: major Component: other
Version: VirtualBox 2.2.4 Keywords:
Cc: Guest type: other
Host type: other

Description

Using the latest Virtualbox on a Linux host.. When I try to delete the current and only snapshot I have, it gives me:

Failed to discard the current snapshot and the current state of the virtual machine winxp.

Hard disk /home/turgut/.VirtualBox/HardDisks/NewHardDisk1.vdi has more than one child hard disk (2). Details:

Result Code: NS_ERROR_FAILURE (0x80004005) Component: HardDisk Interface: IHardDisk {91648dc6-bb19-46bf-9e1c-4bf5b960c8e2}

What shall I do? Thanks, -turgut

Change History

comment:1 Changed 4 years ago by umoeller

  • Status changed from new to closed
  • Resolution set to invalid

This is not a bug, and the behavior has not changed in recent VirtualBox releases (we're at 3.1 now). The solution is to remove the child differencing images in the VirtualBox Media Manager first (main window, "File" menu).

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use