VirtualBox

Ticket #4287 (new defect)

Opened 5 years ago

Last modified 4 years ago

Cursor issues in XP guest while running Eagle Cad with mouse integration

Reported by: fabiop Owned by:
Priority: major Component: guest additions
Version: VirtualBox 2.2.4 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

I am experiencing a problem with Vbox 2.2.4 while running a XP guest OS on a Ubuntu 9.04 Host.

Everything goes fine until I start a PCB design software (Eagle Cad). I can run if succesfully, but when I open de PCB layout window, the cursor disapears. In fact I can still guess it is there, the problem is that it assumes the color of the background (I use a black background color on that program).

When running directly on XP host machine, the cursor is always visible, changing its colors according to the background beneath it (probably an XOR operation).

When running on the XG guest, the cursor is visible outside the drawing area, but when it enters the drawing area its color changes to black making it disapear. (the cursor shape also changes to a crosshair, which is normal).

After playing around with many things, I tried to disable the mouse integration feature on the VM menu and found out that it solves the issue: with mouse integration turned off I can see the cursor on the layout application and it behaves exactly as expected.

Along with that, I am also experiencing poor video performance when redrawing the screens (zomming in and out) on the same application.

I tested the same on a guest running on a VMware server 2.0.1 and I didn't noticed any problem on the VMware one (cursor working ok with mouse integration and a good video performance).

Attachments

XP Dev-2009-06-23-14-03-46.log Download (39.9 KB) - added by fabiop 5 years ago.

Change History

Changed 5 years ago by fabiop

comment:1 follow-up: ↓ 2 Changed 5 years ago by jdshewey

This may be a duplicate of 2603

comment:2 in reply to: ↑ 1 Changed 5 years ago by fabiop

Replying to jdshewey:

This may be a duplicate of 2603

I couldn't find ticket #2603 ...

comment:3 Changed 5 years ago by fabiop

Ops ... After replying the message the wiki link directed me to the ticket ...

comment:4 Changed 4 years ago by FkJ

I'm facing this same cursor issue with Delphi 7. The editor's background color is black and the cursor gets black too when I mouse over it. It happens only when mouse integration is enabled too. Virtual Box and guest additions versions are 3.2.0.

Thanks.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use