VirtualBox

Ticket #4286 (new defect)

Opened 5 years ago

Last modified 5 years ago

can't attach USB device

Reported by: trott Owned by:
Priority: major Component: USB
Version: VirtualBox 2.2.4 Keywords:
Cc: Guest type: Windows
Host type: Mac OS X

Description

I tried to attach an USB Kobil smartcard reader to a windows guest OS.

VirtualBox complains about the device being used by someone else. (Which sounds like some process holding a lock on it to me)

The detailed message is: Fehlercode: NS_ERROR_FAILURE (0x80004005) Komponente: HostUSBDevice Interface: IHostUSBDevice {173b4b44-d268-4334-a00d-b6521c9a740a} Callee: IConsole {9511bc54-15ee-4ddf-808e-472aba03809c}

I also tried this with the "Parallels Desktop": There it works.

Note: Attaching the device results also in an error reported on the MacOS console:

USBF: 12675.455 AppleUSBUHCI[0x2bae000]::Found a transaction past the completion deadline on bus 0x1d, timing out! (Addr: 3, EP: 0)

Change History

comment:1 Changed 5 years ago by mw88

I also have this Problem with an AKS Hardlock plugged into an USB-Port. My version of VirtualBox is 3.0.2 and the Host OS is OS X Server 10.5 and the Guest is Windows 2008 Server.

I experienced this bug when I attach an USB-Device as a filter and then boot the virtual machine. This also happens when I reboot the VM a few times and the only way to solf the problem is to plug the device in another port or reboot the host os.

This is the Errorcode:

Fehlercode:
NS_ERROR_INVALID_ARG (0x80070057)
Komponente:
HostUSBDevice
Interface:
IHostUSBDevice {173b4b44-d268-4334-a00d-b6521c9a740a}
Callee:
IConsole {0a51994b-cbc6-4686-94eb-d4e4023280e2}}}}

comment:2 Changed 5 years ago by ruko

Can't attach a Kobil USB VPN stick to a windows guest OS.
The VirtualBox is 3.0.4 and the host is openSUSE 11.1, 32bit.
The software at the stick does start, but the certificate can't be found.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use