VirtualBox

Ticket #4265 (closed defect: obsolete)

Opened 5 years ago

Last modified 5 months ago

NULL pointer access in VBoxSharedCrOpenGL.DLL crServerAddNewClient (Windows XP host/openSUSE guest)

Reported by: rstevens Owned by:
Priority: major Component: 3D support
Version: VirtualBox 2.2.4 Keywords: OpenGL
Cc: Guest type: Linux
Host type: Windows

Description (last modified by frank) (diff)

When testing some OpenGL screen savers of openSUSE guest in a Windows XP host VB crashes in crServerAddNewClient (access to 0x00000015). (See VS dump file attached)

Attachments

VirtualBox.dmp Download (62.3 KB) - added by rstevens 5 years ago.
Dump file of crash
VBox.log Download (53.2 KB) - added by rstevens 5 years ago.
Log file of session

Change History

Changed 5 years ago by rstevens

Dump file of crash

Changed 5 years ago by rstevens

Log file of session

comment:1 Changed 5 years ago by leonid

Could you please give the exact name of that screensaver you've tried? Because "some" doesn't really help to reproduce the issue. Thanks.

comment:2 Changed 5 years ago by rstevens

Unfortunately not. I was playing around in the Screen Saver dialog when the crash occurs and the VBox window has gone away. So I don't remember what screen saver was selected and caused the crash.

Sorry!

comment:3 Changed 5 years ago by rstevens

I was able to reproduce the behavior with VBox 3.0.2. Screen saver is "KPendulum". Exact guest OS version is: openSUSE 11.1

The error can be reproduced by opening the screen saver configuration, expanding the "OpenGL screen savers" sub tree and selecting the "KPendulum" screen saver.

comment:4 Changed 5 years ago by leonid

Ahha, thanks.

comment:5 Changed 5 months ago by frank

  • Status changed from new to closed
  • Resolution set to obsolete
  • Description modified (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use