VirtualBox

Ticket #4256 (closed defect: fixed)

Opened 5 years ago

Last modified 3 years ago

Guest allocates more RAM than allowed and crashes

Reported by: Sim Owned by:
Priority: major Component: other
Version: VirtualBox 2.2.4 Keywords: RAM
Cc: Guest type: Windows
Host type: Mac OS X

Description (last modified by frank) (diff)

The host owns 2GB RAM and the guest is free to allocate 768MB of this. When I start ressource intensive operations on the guest, after a wgile all the RAM of the host is allocated. If there is no more free RAM available, the guest operation crashes. This phenomenon is reproducable, especially with different installer files. For example, it appeared with the Adobe Reader Installer or the Windows XP Service Pack 3.

First I thought, that the RAM-Module is damaged, but the after exchanging them from the old 2GB memory to new damage-free 4GB the same situation appeared after a while.

Attachments

WinXP-2009-06-17-15-10-30.log Download (48.0 KB) - added by Sim 5 years ago.

Change History

Changed 5 years ago by Sim

comment:1 Changed 5 years ago by frank

  • Description modified (diff)
  • Summary changed from Host allocates more RAM than allowed and crashes to Guest allocates more RAM than allowed and crashes

It depends on your host how much memory you should assign to a VM. If there are many ressource-intensive applications running on your host then you should decrease the memory you assigned to the guest.

Apart from this, it is a known issue on Darwin that concurrent hard disk activity on the host will delay virtual hard disk operations in a VBox VM so that the guest gets confused because an IDE operation took too long. We are working on a workaround for that problem but the initial question for your system is where the high disk load comes from.

Btw, don't switch host and guest: The host is the physical machine (plus the operating system on it), the guest is living in the virtual machine.

comment:2 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if still relevant with VBox 4.0.4.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use