VirtualBox

Ticket #4254 (closed defect: fixed)

Opened 5 years ago

Last modified 15 months ago

graphics corruption when using xorg-server-1.6

Reported by: maruchi Owned by:
Priority: major Component: GUI
Version: VirtualBox 2.2.4 Keywords: graphics corrupt
Cc: Guest type: Windows
Host type: other

Description (last modified by frank) (diff)

When using xorg-server-1.5, the virtualbox showed correct graphics. No problem. But using xorg-server-1.6.1.901 makes graphics corrupt. I'm using Radeon Mobility X600 with xf86-video-ati-6.12.2 open driver.

I restarted my X, the first run of VirtualBox was working. After that, corrupted screen again.

I'll attach a screenshots to illustrate what I'm talking about.

Attachments

video_corruption_resized.png Download (264.7 KB) - added by maruchi 5 years ago.
Screenshot of the corrupt VBox guest

Change History

Changed 5 years ago by maruchi

Screenshot of the corrupt VBox guest

comment:1 Changed 5 years ago by michael

Does restarting the host X server always fix this once off?

comment:2 Changed 5 years ago by maruchi

Yes. Like I said, after restarting X, the first run of VirtualBox shows the correct screen. But the second run makes the screen corrupt.

comment:3 Changed 5 years ago by maruchi

I guess this is Guest Additions related. I have Guest Additions installed only on WindowsXP.

Dos guest doesn't have any problem. After running Dos guest, the run of WindowsXP guest shows correct screen. But after running WindowsXP guest, the run of Dos makes screen corrupt.

comment:4 Changed 5 years ago by michael

Can you try uninstalling the Guest Additions from your XP guest to test this? You may want to make a snapshot of the guest before you do so.

comment:5 Changed 5 years ago by maruchi

The problem is solved and was not the Guest Additions related. I changed "accelerate3D" from "true" to "false" and the problem vanished away. I remember I did check the checkbox of "Enable 3D Acceleration" in the Settings window months ago(or a year ago?). The strange thing is that the checkbox is greyed out now, so I couldn't check/uncheck it. I VIMed the "WindowsXP.xml" file.

Anyway my problem is solved. Thank you.

comment:6 Changed 5 years ago by leonid

Checkbox is grayed out means your host doesn't provide necessary 3d support. In normal situation it shouldn't be possible to enable this option unless your host suports it, the only problem is that this check was added recently.

comment:7 Changed 5 years ago by maruchi

Reading your explanation brings back my memory.
When I enabled this option, I was using ATI proprietary drivers. I'm sorry I didn't clarify that.

Let me be brief:

  1. xorg-server-1.5 and ATI proprietary drivers.

--> Enabled 3D acceleration option. No problem.

  1. xorg-server-1.5 and xf86-video-ati opensource drivers.

--> No problem.

  1. xorg-server-1.6 and xf86-video-ati opensource drivers.

--> The problem occurred. Disabling the option solved the problem.

comment:8 Changed 15 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
  • Description modified (diff)

Please reopen if still relevant with VBox 4.2.6.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use