VirtualBox

Ticket #4201 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

VBox 2.2.4 segfaults after heavy I/O => Fixed in 3.0

Reported by: sub.mesa Owned by:
Priority: major Component: other
Version: VirtualBox 2.2.4 Keywords:
Cc: Guest type: other
Host type: other

Description

Also see this topic:  http://forums.virtualbox.org/viewtopic.php?f=7&t=18462

I get regular segfaults when running VirtualBox 2.2.4 or 2.2.2 PUEL on Ubuntu 9.04 amd64, with guest OS FreeBSD 7-STABLE amd64. The dmesg shows:

[60327.316891] VirtualBox[21681]: segfault at 20 ip 00007f159fd66c32 sp 00007f1536ba5e10 error 4 in VBoxVMM.so[7f159fcbd000+12a000]

[164613.347935] VirtualBox[19352]: segfault at 20 ip 00007f5b68567c32 sp 00007f5afb112e10 error 4 in VBoxVMM.so[7f5b684be000+12a000]

The segfaults occur while performing heavy I/O on 8 raw disks attached via AHCI. The heavy I/O originates from a ZFS RAID-Z ("RAID5") configuration on those 8 disks, and performing a scrub on the volume, which is 100% disk bound and takes little over an hour to complete. But often the crash is triggered within the first run, between 30-50 minutes.

On the third try, i tried to run a backtrace and dump. Logs attached, but the dump is over 1.7GB. I could try reducing the memory to reduce the dumpsize, but ZFS likes to use lots of memory so this could be problematic. I've already tried 5-passes with Memtest86+ so memory corruption is not an issue here. I think these crashes are a defect of Virtualbox, and would like help to debug this thing.

Kind regards, sub

Attachments

FreeBSD 7-2009-06-05-16-59-28.log Download (40.9 KB) - added by sub.mesa 5 years ago.
vbox log
FreeBSD7-coredump-output.txt Download (6.9 KB) - added by sub.mesa 5 years ago.
coredump (gdb)

Change History

Changed 5 years ago by sub.mesa

vbox log

Changed 5 years ago by sub.mesa

coredump (gdb)

comment:1 Changed 5 years ago by sub.mesa

Additional information:

  • I already did a surface scan on all 8 disks used as raw disks by the Guest OS
  • On the third try, with logs attached, i started my VM directly using:

/usr/lib/virtualbox/VirtualBox -startvm "FreeBSD 7"

  • I created the raw disks by using the "VBoxManage internalcommands createrawvmdk" method

Hardware is an AMD X2 6000+ (frequency ranging 1.0-3.0GHz using CnQ), nForce 570 SLI chipset with 6 SATA ports, and additional PCIe 2-port SATA controller. System disk is on PATA, and also stores the system disk for the guest OS.

Any feedback into diagnosing this issue is appreciated.

comment:2 Changed 5 years ago by frank

sub.mesa, a core dump should help us finding the problem. If you would like to provide some core dump please contact me via private E-mail at frank _dot_ mehnert _at_ sun _dot_ com.

comment:3 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
  • Summary changed from VBox 2.2.4 segfaults after heavy I/O to VBox 2.2.4 segfaults after heavy I/O => Fixed in 3.0

Status update: It appears that this bug should be fixed in VBox 3.0 (test VBox 3.0.4 please). Please reopen if this problem persists with VBox 3.0.4.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use