VirtualBox

Ticket #4197 (closed defect: invalid)

Opened 5 years ago

Last modified 4 years ago

VirtualBox not working with FreeNAS iSCSI targets

Reported by: HolgerB Owned by:
Priority: minor Component: virtual disk
Version: VirtualBox 2.2.4 Keywords: iSCSI target FreeNAS
Cc: Guest type: other
Host type: Linux

Description

I'm using an Ubuntu 8.10 AMD64 host here running VirtualBox 2.2.2 r46594.

I've set up an iSCSI target using FreeNAS with the following version:

0.69.1 Omnius (revision 4554) built on Sat Apr 18 23:20:57 UTC 2009

I've added the iSCSI target I generated to the available VBox medias with the following command: VBoxManage addiscsidisk --server 192.168.0.166 --target iqn.1994-04.org.netbsd.iscsi-target:target0

The target was correctly added (at least VBox doesn`t report any issues). Unfortunately VBox reports the iSCSI target always as not ready / unaccessable.

When I attach the target to a VM and start the machine with an ISO attached for guest OS installation the following message appears: Medium '192.168.0.166|iqn.1994-04.org.netbsd.iscsi-target:target0' is not accessible. Could not open the hard disk '192.168.0.166|iqn.1994-04.org.netbsd.iscsi-target:target0'. VD: error opening image file '192.168.0.166|iqn.1994-04.org.netbsd.iscsi-target:target0' (VERR_TIMEOUT).

Fehlercode: NS_ERROR_FAILURE (0x80004005) Komponente: Machine Interface: IMachine {13420cbb-175a-4456-85d0-301126dfdec7}

I can at least confirm that iSCSI targets generated with FreeNAS work fine with a WinXP host and the Microsoft iSCSI initiator. I can perfectly access those targets, format the "disk" and assign them to the host.

On the other hand I could use the VBox iSCSI feature by setting up an iSCSI target with the userspace implementation on my Ubuntu host. Strange....

Attachments

patch-statsn Download (258 bytes) - added by 403 5 years ago.

Change History

comment:1 Changed 5 years ago by 403

This is a bug in netbsd-iscsi, see the attached patch.

Changed 5 years ago by 403

comment:2 Changed 5 years ago by HolgerB

@403: Thanks for pointing out. So it´s actually a problem of the FreeNAS iSCSI target implementation. Could you please elaborate the problem a bit more and provide a bit more information on your patch (e.g. what you changed because of what reason). I would like to forward this to the FreeNAS developers. I think FreeNAS is nice option for building a NAS on budget and for me it looks more stable than OpenFiler.

TIA, HolgerB

comment:3 Changed 5 years ago by 403

It seems that FreeNAS 0.7 is going to use another iscsi target implementation -- istgt so they might not care for netbsd-iscsi. The problem is that the target sets the StatSN field of the second login response to an unexpected value which confuses virtualbox. The reason is sess->StatSN not being in sync with the StatSN sent in the first login response and a simple fix is in the patch.

comment:4 Changed 4 years ago by aeichner

  • Status changed from new to closed
  • Resolution set to invalid
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use