VirtualBox

Ticket #4165 (closed defect: duplicate)

Opened 5 years ago

Last modified 5 years ago

Using NAT, ssh logins from Guest to Host disconnect under high CPU Usage

Reported by: pablo Owned by:
Priority: major Component: network/NAT
Version: VirtualBox 2.2.4 Keywords: nat disconnects guest to host
Cc: Guest type: Windows
Host type: Linux

Description

Howdy,

My environment is the following:

  • Host O/S: openSUSE 11.0
  • Guest O/S: Win XP/SP3

On the Guest O/S I run Cisco VPN software. I also run ssh (cygwin) to setup port-forwarding between my Host O/S and the Guest O/S

With the above setup, my browser on my Host O/S can access the internal web servers via the VPN. In short, the Guest O/S acts like a bridge.

The above works very well when I use either NAT or Bridging for the Guest O/S

The problem is, and I'm not 100% sure this is the cause, when my Host O/S is under heavy CPU load and I'm using NAT, the ssh connection between my Guest O/S and Host O/S drops. As I'm also sshd to the remote servers, these connections are dropped.

The above only happens when I'm running a browser which is displaying Oracle Grid data (somewhat CPU intensive) and I'm using NAT

If I use Bridging on the Guest O/S, the problem never occurs.

As I travel at times, I can't always use Bridging on the Guest O/S

Please let me know how additional forensics can be collected so we can resolve the issue.

Attachments

notes Download (486 bytes) - added by pablo 5 years ago.
Comments on the VBox.log
VBox.log Download (47.8 KB) - added by pablo 5 years ago.
Log file with NAT enabled and a disconnect.
ssh-vvvv Download (1.8 KB) - added by pablo 5 years ago.
"ssh" session with high verbosity set - tail end; shows disconect

Change History

comment:1 in reply to: ↑ description Changed 5 years ago by Hachiman

Could you please attach log file when it happens with NAT.

Changed 5 years ago by pablo

Comments on the VBox.log

Changed 5 years ago by pablo

Log file with NAT enabled and a disconnect.

Changed 5 years ago by pablo

"ssh" session with high verbosity set - tail end; shows disconect

comment:2 Changed 5 years ago by pablo

Hi,

Thank you for the quick response. Please see the attached files. Please advise if I need to collect additional data.

Cheers, -pablo

comment:3 Changed 5 years ago by Hachiman

  • Status changed from new to closed
  • Resolution set to duplicate

duplicate #4540

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use