VirtualBox

Ticket #4150 (closed defect: worksforme)

Opened 5 years ago

Last modified 4 years ago

VirtualBox Networking does not pass DCE RPC BIND packets with OS X host

Reported by: fm2503 Owned by:
Priority: major Component: network/NAT
Version: VirtualBox 3.0.4 Keywords: outlook exchange
Cc: Guest type: Windows
Host type: Mac OS X

Description (last modified by Hachiman) (diff)

Host: OS X 10.5.7 Guest: Vista 32 bit, SP1. Outlook 2007 SP2 (Also happens with Win7) Networking: Bridged to wired ethernet (also happens with NAT)

Windows Vista/Win7 guests are unable to connect to Exchange 2003 using MAPI. The DCE RPC BIND packet sent from the guest never leaves the host. Attached screen shots show wireshark captures from the guest and the host.

Packet 744 (the last one in the guest trace), never appears in the host trace. This happens regardless of the type of NIC emulated in the guest (Intel and PCnet-FAST III) tested.

The X.X.67.255 box is the Vista guest client and the X.X.55.71 box is the Exchange server. The .255 is valid as an ip address for the client as a large netmask is being used.

This prevents outlook from communicating with Exchange.

All firewalls on host and guest disabled.

Present since at least 2.1.2 on OS X

Attachments

OnTheHost.gif Download (39.9 KB) - added by fm2503 5 years ago.
Host packet capture screenshot
OnTheGuest.gif Download (76.4 KB) - added by fm2503 5 years ago.
guest packet capture screenshot
VBox-1.log Download (61.5 KB) - added by fm2503 5 years ago.
VBox log included
VBox.log Download (58.4 KB) - added by fm2503 5 years ago.
Log file when NAT networking used. (Other log is with bridged)

Change History

Changed 5 years ago by fm2503

Host packet capture screenshot

Changed 5 years ago by fm2503

guest packet capture screenshot

comment:1 Changed 5 years ago by fm2503

Note - all other windows networking (file shares, browsing, HTTP, kerberos) seem to be working fine.

Changed 5 years ago by fm2503

VBox log included

comment:2 Changed 5 years ago by Hachiman

Could you please add log for the same issue with NAT networking?

Changed 5 years ago by fm2503

Log file when NAT networking used. (Other log is with bridged)

comment:3 follow-up: ↓ 4 Changed 5 years ago by fm2503

A bit more information. I've been through the normal outlook issue steps of deleting and recreating the mail profiles. At one point I suspect the guest OS, but even with clean installs of both Vista and Win7 plus O2K7 the issue is repeatable and happens every time.

comment:4 in reply to: ↑ 3 ; follow-up: ↓ 5 Changed 5 years ago by Hachiman

Replying to fm2503:

A bit more information. I've been through the normal outlook issue steps of deleting and recreating the mail profiles. At one point I suspect the guest OS, but even with clean installs of both Vista and Win7 plus O2K7 the issue is repeatable and happens every time.

Would you mind to send me (vasily[dot]levchenko[at]Sun[dot]COM) pcap file of guest to NAT interaction (please see  pcap for details)

comment:5 in reply to: ↑ 4 Changed 5 years ago by fm2503

Replying to Hachiman:

Would you mind to send me (vasily[dot]levchenko[at]Sun[dot]COM) pcap file of guest to NAT interaction (please see  pcap for details)

Annonmised pcap mailed as requested.

comment:6 follow-up: ↓ 7 Changed 5 years ago by robmoore

I'm seeing something similar but I have a Ubuntu 9.04 host and a Windows XP guest. Also, I've had success connecting to Exchange but only intermittently and after a wait of 10 minutes or so. I can provide pcap data if desired.

comment:7 in reply to: ↑ 6 Changed 5 years ago by Hachiman

Replying to robmoore:

I'm seeing something similar but I have a Ubuntu 9.04 host and a Windows XP guest. Also, I've had success connecting to Exchange but only intermittently and after a wait of 10 minutes or so. I can provide pcap data if desired.

Thanks for information, please do it. will compare and will try found some solution

comment:8 in reply to: ↑ description ; follow-up: ↓ 9 Changed 5 years ago by Hachiman

BTW: Is it new issue appeared in 2.2.4 or it presents in 2.0, 2.1 as well?

comment:9 in reply to: ↑ 8 Changed 5 years ago by fm2503

Replying to Hachiman:

BTW: Is it new issue appeared in 2.2.4 or it presents in 2.0, 2.1 as well?

It certainly wasn't present in 1.6, nor I think 2.0. Unfortunatley I switched from an Ubuntu host to a OS X around the 2.1 time frame, so can't be certain when exactly it broke.

IIRC the problem manifested itself around the 2.2 time frame. I think 2.1 was OK, but am not in a position to test at the moment. Could probably do a binary chop to determine exact version this regression was introduced, but that will have to wait for the weekend.

Matt

comment:10 follow-ups: ↓ 11 ↓ 12 Changed 5 years ago by robmoore

I've sent the pcap file to your email. A small note, in the pcap instructions you link to the command line options are a bit out of date -- it appears the option is modifyvm rather than just modify.

comment:11 in reply to: ↑ 10 Changed 5 years ago by Hachiman

Replying to robmoore:

I've sent the pcap file to your email. A small note, in the pcap instructions you link to the command line options are a bit out of date -- it appears the option is modifyvm rather than just modify.

Thank you for files, and noticing mistype on wiki (updated).

comment:12 in reply to: ↑ 10 ; follow-up: ↓ 13 Changed 5 years ago by fm2503

I've done some version testing and on OS X the problem is present in 1.6.4 2.0.8 2.1.4 and 2.2.4. Clearly this is an OS X specific thing, as I didn't see this issue on Kubuntu at all.

comment:13 in reply to: ↑ 12 Changed 5 years ago by Hachiman

Replying to fm2503:

I've done some version testing and on OS X the problem is present in 1.6.4 2.0.8 2.1.4 and 2.2.4. Clearly this is an OS X specific thing, as I didn't see this issue on Kubuntu at all.

Thank you for update and investigation.

comment:14 Changed 5 years ago by fm2503

This seems to be a generic problem with the RPC traffic and VB on OS X. Using a host only network I was unable to domain join a W2K03SP2 box to a 2K08 domain until I followed the steps listed in  http://support.microsoft.com/kb/899148

Notably I set Server2003NegotiateDisable to 1, and then the 2K03SP2 box was able to join the domain. Without this flag set, the box could not join the domain and failed with RPC errors.

Sadly Server2003NegotiateDisable doesn't solve the problem for Vista and outlook to talk MAPI to exchange

comment:15 Changed 5 years ago by fm2503

Having said that, I've flicked the Vista VM to bridged networking, and my connectivity to Exchange is restored. I'll double check the NAT configuration. Server2003NegotiateDisable certainly works around the problem using bridged networking.

comment:16 Changed 5 years ago by fm2503

OK, the situation is confirmed. With host only or bridged networking Server2003NegotiateDisable set allows these RPC packets to pass, and connectivity is achieved. With NAT networking the problem remains.

Hope this helps.

comment:17 Changed 5 years ago by fm2503

Issue is still present with NAT networking under version 3.0.2. Bridged continues to work fine.

comment:18 follow-ups: ↓ 20 ↓ 21 Changed 5 years ago by fm2503

I've upgraded to 3.0.4 and on first glance the problem remained. However I have been able to establish connectivity with Exchange by authenticating in the format fqdn.domain.name.com\user.name and configuring the security settings on the exchange account for Logon network security to "Negotiate Authenticaiton".

So whilst there are various scenarios that do not work, these could equally be down to outlook/exchange strangeness, although server2003NegotiateDisable does seem to be still required.

As a valid work around now exists I'm happy for this to be closed.

comment:19 Changed 5 years ago by Hachiman

  • Version changed from VirtualBox 2.2.4 to VirtualBox 3.0.4
  • Component changed from network to network/NAT

comment:20 in reply to: ↑ 18 Changed 5 years ago by Hachiman

Replying to fm2503:

Thank you for publishing workaround.

comment:21 in reply to: ↑ 18 Changed 5 years ago by Hachiman

  • Description modified (diff)

Replying to fm2503: Could please collect the pcap files for 2.1 and 3.0.4 releases? Still not sure what is real problem for dropping this packets.

comment:22 Changed 5 years ago by Hachiman

  • Description modified (diff)

comment:23 Changed 4 years ago by Hachiman

No response, closing. Please feel free to reopen if problem still persists.

comment:24 Changed 4 years ago by Hachiman

  • Status changed from new to closed
  • Resolution set to worksforme
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use