VirtualBox

Ticket #4118 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

Multiple VMs on single TAP device fails

Reported by: AndersKOlsson Owned by:
Priority: blocker Component: network/hostif
Version: VirtualBox 2.1.4 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description

When I start multiple VMs that all have Host Interface Networking, and are using the same TAP device, only the one started first successfully start. The subsequently started VM fail with: "Failed to open Host Interface Network device driver (VERR_PDM_HIF_OPEN_FAILED)"

The Host OS is Vista 32-bit. The Guest OSes is Linux 64-bit. The virtual NICs are PCnet-FAST III.

This configuration works well on Linux with a TAP device.

The way I see it, using a single TAP with multiple VMs is the only way to go if you need a configuration where there is two-way communication between both Guest-Host and Guest-Guest.

I haven't tested this in a newer version that 2.1.4, because I found no fitting fixed bug rapport in the release notes of the newer versions.

The errors reported in the logs: "00:00:01.609 PDM: Failed to construct 'pcnet'/0! VERR_PDM_HIF_OPEN_FAILED (-2852) - Unable to open the host interface. 00:00:01.611 ERROR [COM]: aRC=E_FAIL (0x80004005) aIID={e3c6d4a1-a935-47ca-b16d-f9e9c496e53e} aComponent={Console} aText={Failed to open Host Interface Networking device driver (VERR_PDM_HIF_OPEN_FAILED). 00:00:01.611 Unknown error creating VM (VERR_PDM_HIF_OPEN_FAILED)} aWarning=false, preserve=false 00:00:01.619 Power up failed (vrc=VERR_PDM_HIF_OPEN_FAILED, rc=E_FAIL (0X80004005)) 00:01:04.004 ERROR [COM]: aRC=VBOX_E_INVALID_VM_STATE (0x80bb0002) aIID={e3c6d4a1-a935-47ca-b16d-f9e9c496e53e} aComponent={Console} aText={Invalid machine state: 1)} aWarning=false, preserve=false"

Attachments

VBox.log Download (28.4 KB) - added by AndersKOlsson 5 years ago.
A single failed run of a second machine using the single TAP device

Change History

Changed 5 years ago by AndersKOlsson

A single failed run of a second machine using the single TAP device

comment:1 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

Works as designed. As of 2.2.0 we've introduced a new networking model that has no such restrictions.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use