VirtualBox

Ticket #4103 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

Host networking negatively influenced by VBox

Reported by: bauer40 Owned by:
Priority: major Component: network
Version: VirtualBox 2.2.2 Keywords:
Cc: Guest type: Windows
Host type: Windows

Description (last modified by frank) (diff)

Hi Folks!

Problem on WinXP/SP3 host, same with MS Vista Business 32 Bit/SP1: After installing VBox 2.2.2, the Dell 1600n scan driver doesn't work anymore. The Network Scan driver simply does not find the printer/scanner.

De-installing VBox leads to a working setup. Thus, I can say, that the inserted network module of virtual box is not completly transparent.

Setup: A switched network with two Windows PCs, each running WireShark. The system with VBox has an additional Host-Only Network. Furthermore, there is a Dell 1600n Printer/Scanner.

Abstract: When searching for a printer/scanner, the dell software broadcasts an UDP Packet with the source address of the host, destination address=255.255.255.255, UDP Port 1124.

Error description:

  1. Searching for the printer when VBox is NOT installed: the UDP-Packet is seen on the host running VBox, and the Printer/Scanner correctly responds.
  2. Searching for the printer when VBox IS installed: the UDP Packet is sent on the physical network interface with the source IP address of the Host-Only-Network.
  3. Disabeling the Host-Only-Network in the Windows Network Setup let's the UDP Packet vanish in whole.
  4. De-Installing the VBox Host-Only Network card does not help at all.

Is there anything more I can to do isolate the problem?

Peter

Change History

comment:1 Changed 5 years ago by frank

  • Description modified (diff)

comment:2 follow-ups: ↓ 3 ↓ 4 ↓ 5 Changed 5 years ago by misha

Which VBox version did you use prior 2.2.2? Does this happen with VBox 2.2.2 only?
Could you try disabling VirtualBox Host-Only Ethernet Adapter(s) in device menager and see if it solves the problem?
If the above does not help could you open the properties dialog for your physical adapter's network connection and disable (uncheck) the VirtualBox Bridged Networking Driver there and see if that helps (after closing the properties dialog ofcourse :)

comment:3 in reply to: ↑ 2 Changed 5 years ago by bauer40

Replying to misha:

Which VBox version did you use prior 2.2.2? Does this happen with VBox 2.2.2 only?

I tested 2.1.4, which had no problem. The problem was introduced in VBox 2.2.0.

I'll go for further tests.

comment:4 in reply to: ↑ 2 Changed 5 years ago by bauer40

Replying to misha:

Which VBox version did you use prior 2.2.2? Does this happen with VBox 2.2.2 only?

  • 2.1.4 - no problem
  • 2.2.0 with a Host-Only NIC: faulty
  • 2.2.0 without a Host-Only NIC: OK
  • 2.2.2 with a Host-Only NIC: faulty
  • 2.2.2 without a Host-Only NIC: OK

Having the VBox Bridged Networking Driver on the physical interface active or not does not influence the problem.

It' proven that outgoing packets carry the source IP address of the Host-Only-NIC if there is a Host-Only-NIC, which has not been deactivated.

OK, furthers tests:

  • I removed the IP address from the host-only NIC, having it to auto-IP. The packets on the network still use the source IP address of the Host-Only NIC.
  • Setting the IP address of the host-only NIC to the same as the physical NIC is illegal (says windows), and so I canceled that test.
  • I deactivated the Host-Only Network. Now, the outgoing UDP packets use the correct source address.
  • I reactivated the Host-Only Network. Again, the packets use the Host-Only NIC IP address instead of the address of the physical NIC.

I start thinking about who's responsible in Windows Network Programming for selecting the source IP address... could it be a problem of the Dell Network Scan driver that it sets a wrong source IP address when it creates the UDP Socket?

comment:5 in reply to: ↑ 2 Changed 5 years ago by bauer40

Replying to misha:

Which VBox version did you use prior 2.2.2? Does this happen with VBox 2.2.2 only?
Could you try disabling VirtualBox Host-Only Ethernet Adapter(s) in device menager and see if it solves the problem?
If the above does not help could you open the properties dialog for your physical adapter's network connection and disable (uncheck) the VirtualBox Bridged Networking Driver there and see if that helps (after closing the properties dialog ofcourse :)

I'm out-of-office for the next two weeks, so I cant do further tests. I'll take a look at this ticket when I'm back.

Peter

comment:6 follow-up: ↓ 7 Changed 5 years ago by bauer40

Updated to 2.2.4 - Bug is still there.

comment:7 in reply to: ↑ 6 Changed 5 years ago by misha

Replying to bauer40: Could you try changing the host-only connection priority and see if it solves your issue?
To do this:

  1. press "Start" button
  2. right-click "Network" and select "Properties"
  3. in the left pane press "Manage Network Connections"
  4. in the "Network Connections" window press "Alt" button -> this will make advanced menu to apear
  5. select "Advanced" -> "Advanced Settings" -> this will open the "Advanced Settings" dialog
  6. in the dialog select the host-only network connection and move it to the bottom using the "down-arrow" button of the dialog

comment:8 follow-ups: ↓ 9 ↓ 10 Changed 5 years ago by bauer40

Yes, that is a fix.

After creating a new Host-Only-Network it's on the beginning of the list - right OVER the physical network interface.

Moving it BELOW the physical NIC solves that problem.

So, is it a problem of VBox or a strange way the Dell software selects it's source IP Address?

comment:9 in reply to: ↑ 8 Changed 5 years ago by bauer40

Replying to bauer40:

Yes, that is a fix

However, I did not test host-only networking right now...

comment:10 in reply to: ↑ 8 Changed 5 years ago by misha

Replying to bauer40: Thanks for the test! Moving the host-only priority down should not affect host-only networking I guess.
We'll work for the fix to make the host-only priority be properly set automatically.

comment:11 follow-up: ↓ 12 Changed 5 years ago by misha

We've made fixes to host-only interface for 3.0 for Windows host, could you try VBox 3.0 to see whether the issue is gone?

comment:12 in reply to: ↑ 11 Changed 5 years ago by bauer40

Replying to misha:

We've made fixes to host-only interface for 3.0 for Windows host, could you try VBox 3.0 to see whether the issue is gone?

Yes, it seems to work well. I've tested it by updating 2.2.4 on one System and did a fresh install on another - in both cases, the Host-Only-NIC goes to the end of the list, right before the Remote Access Connections (sorry, german XP, so I translated RAS-Verbindungen best I can).

I think you could close this ticket. Well done, misha! Great job.

comment:13 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use