VirtualBox

Ticket #41 (closed defect: fixed)

Opened 7 years ago

Last modified 4 years ago

GuestAdditions for Linux - breaks graphics - quadruples resolution in X

Reported by: Technologov Owned by:
Priority: major Component: other
Version: VirtualBox 1.3.4 Keywords:
Cc: Guest type: other
Host type: other

Description

Testbeds (Hosts):

Software1: Windows XP Pro SP2 Eng, no extra patches, VirtualBox 1.3.4 Full.

Software2: Windows XP Pro SP2 Eng, no extra patches, VirtualBox 1.3.2 Full.

Software3: openSUSE 10.2, VirtualBox 1.3.4 Full.

Software4: openSUSE 10.2, VirtualBox 1.3.2 Full.

Guest OSes: openSUSE 10.2 and SUSE Linux 10.0

Those VMs run fine before I install guest additions. LinuxAdditions breaks them totally. More specifically, it quadruples the X-server resolution to something huge like 2000x2000 or more... making it impossible to navigate such systems.

Steps to reproduce:

Install GuestAdditions for Linux on the guest OSes specified above and restart.

Before you suicide I recommend:

a) backup your guest OS VDI image

b) setup /etc/inittab to start with runlevel 3 (so your system will be navigatable without X)

Bad Workaround: kill X server (init 3), setup /etc/inittab to start with runlevel 3, reconfigure X-server to normal resolution (800x600x16-bit) (with sax2), restart X server (init 5).

Question: How to switch to a different tty when working under Linux with X on both host and guest? as "ctrl+alt+F1" combo switches the host, not the guest.

-Alexey Eremenko

Change History

comment:1 Changed 7 years ago by Technologov

this bug is related to bug #31

comment:2 Changed 7 years ago by frank

Fixed the issue where the VM window was much bigger than the host screen. If no default X video mode is specified, 1024x768 is used now.

To switch to a different guest VT execute chvt in the guest. The VBoxSDL GUI knows the combination HostKey+Fx which is interpreted as CTRL+ALT+Fx. A similar approach is about to be implemented in the Qt GUI.

comment:3 Changed 7 years ago by Technologov

Please use 800x600 by default instead of 1024x768.

My real screen is 1024x768, so having a VM in that resolution won't enable me to navigate it in windowed mode.

comment:4 Changed 7 years ago by Technologov

Verified with 1.3.6, and the bug still exists.

Software: Windows XP Pro SP2 Eng, no extra patches, VirtualBox 1.3.6 Full+Additions from Linux Host. (done due to:  http://www.virtualbox.org/ticket/91)

-Alexey Eremenko

comment:5 Changed 7 years ago by frank

Are you sure that you upgraded your Linux guest additions to 1.3.6? The change was actually made in the Linux guest video driver. It is best to first uninstall the old guest additions and the install the new one.

comment:6 Changed 7 years ago by Technologov

NOTE: I might have older vbox additions installed, and then upgraded to new ones. I have found no way to uninstall guest additions (not WinAdditions and not LinAdditions). This topic in undocumented.

I updated additions to 1.3.6 according to *your* documentation:

4.3.3. Updating the Linux Guest Additions

The Guest Additions can simply be updated by going through the installation procedure again with an updated CD-ROM image. This will replace the drivers with updated versions. You should reboot after updating the Guest Additions.

If this documentation is buggy, hmmm... well, then I should open an additional bug on the same topic.

-Alexey Eremenko

comment:7 Changed 7 years ago by Technologov

One workaround, that I found: set guest video RAM to 1MB.

-Alexey Eremenko

comment:8 Changed 7 years ago by frank

This should be really fixed now with 1.3.8, even for openSUSE.

comment:9 Changed 7 years ago by Technologov

Fix verified with 1.3.8. Product Works excellent.

On a side note: please lower default resolution from 1024x768 to 800x600 since not all screens support this resolution. (not my anyways)

-Alexey Eremenko

comment:10 Changed 7 years ago by Technologov

Please close this bug.

comment:11 Changed 7 years ago by michael

  • Status changed from new to closed
  • Resolution set to fixed

comment:12 Changed 7 years ago by Technologov

  • Status changed from closed to reopened
  • Resolution fixed deleted

It's too bad that this problem was not really fixed, just hidden.

In short: today I have installed openSUSE 10.3 (BETA1) guest, and after installing guest additions, the resolution automatically switched to 1024x768, which is way too high, and what's worse, is the fact that "KRand" application that I use to switch resolutions, cannot find any resolutions other than 1024x768. Using SUSE's sax2 utility allows me to force resolution to 800x600, but it removes mouse integration which is totally unacceptable behavior.

Correct behavior: VirtualBox *should* generate better x.org.conf files, that use lower resolution by default (800x600), plus allow resolution reduction via "KRand" application.

Host: openSUSE 10.2, vbox 1.4.0. Guest: openSUSE 10.3 BETA 1.

-Technologov

comment:13 Changed 7 years ago by frank

vboxvideo now has three default resolutions: 1024x768, 800x600, 640x480 which are all available to the xrand extension. 1024x768 is default if no resolution is specified in xorg.conf. Later we will add a feature that requests the hosts screen resolution and selects the next smaller resolution than the host.

comment:14 Changed 7 years ago by Technologov

Another great idea would be to go the VMware way:

Allow the end user to choose his virtual screen max. resolution. VMware Workstation 6 can do it. This way guest cannot use higher resolution, than available by virtualizer's monitor. This will also solve the problem for Knoppix/Ubuntu/... LiveCDs that automatically go full screen, even if I don't want them to.

comment:15 Changed 7 years ago by sandervl73

  • Status changed from reopened to closed
  • Resolution set to fixed

Reopen if still relevant.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use