VirtualBox

Ticket #4092 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

Using clipboard on guest locks host from using it -> fixed in 3.0.6

Reported by: caldo_de_cana Owned by:
Priority: major Component: clipboard
Version: VirtualBox 3.0.4 Keywords:
Cc: Guest type: Linux
Host type: Mac OS X

Description

If I copy some text in the guest OS with ctrl+c (Ubuntu 8.10), I can paste it in the host OS with cmd+v (Mac OS X 10.5), as expected.

But sometimes when I copy some text in the host OS with cmd+c (after the clipboard has had some text copied into it by the guest OS), the text will not be copied to the clipboard (neither in the host nor the guest OS). To get the clipboard back I have to randomly copy some text in the guest and host OS until I get what I wanted. I have not been able to find an exact cause or minimal steps to reproduce.

Attachments

strace.out Download (53.1 KB) - added by kurtraschke 5 years ago.
Output from strace while "VBoxClient --clipboard -d" consumes 100% CPU
VBox.log.zip Download (7.7 KB) - added by kurtraschke 5 years ago.
gdb.txt Download (7.2 KB) - added by kurtraschke 5 years ago.

Change History

comment:1 Changed 5 years ago by michael

It would be great if you could find a recipe for reproducing this so that we can test.

comment:2 Changed 5 years ago by kurtraschke

Unfortunately I cannot contribute a recipe for reproducing this bug, but I can say that I am seeing the same problem with Mac OS X 10.5.7, VirtualBox 3.0.2, and an Xubuntu 9.04 guest. I have found that when the clipboard malfunctions, the VBoxClient --clipboard process on the guest starts consuming around 75% of the guest CPU, and VirtualBox starts consuming 102-105% of the host CPU.

Can VBoxClient be configured to run verbosely or with debugging information?

comment:3 Changed 5 years ago by michael

kurtraschke: did you update the Guest Additions to version 3.0.2 as well? If you did and still see this issue then I will look at providing you with a version of VBoxClient that can run more verbosely.

Changed 5 years ago by kurtraschke

Output from strace while "VBoxClient --clipboard -d" consumes 100% CPU

comment:4 Changed 5 years ago by kurtraschke

I have updated the Guest Additions to 3.0.2, and the issue persists. I have attached the output from a run of strace on VBoxClient --clipboard while the VBoxClient process was consuming full CPU.

comment:5 Changed 5 years ago by michael

Sorry for the delay in getting back to you! Here are two test builds of the Additions, one which works on a 32bit (K/X)Ubuntu 9.04 guest, and one for a 64bit one. As usual, the builds should only be used for testing this particular problem (and the links will in fact expire in a week or so).

 http://www.virtualbox.org/download/testcase/VBoxGuestAdditions-r50558-x86-Ubuntu-9.04.iso

and

 http://www.virtualbox.org/download/testcase/VBoxGuestAdditions-r50558-amd64-Ubuntu-9.04.iso

If you install the right one of these, and run VBoxClient -d --clipboard with the following environment variables set:

VBOX_LOG_DEST=file
VBOX_LOG=all.e.l.l2.l3.f

it will produce a log file which should provide more information about what it is doing. Since these builds also include debugging symbols, you could also (if you have experience with that sort of thing) break in with a debugger when the programme gets stuck and get an all-threads backtrace and information about local variables ("info locals" in gdb IIRC) for both threads.

Changed 5 years ago by kurtraschke

Changed 5 years ago by kurtraschke

comment:6 Changed 5 years ago by kurtraschke

I've attached logs from the debugging build of VBoxClient posted above. In this case, all I had to do in order to get VBoxClient to go into a loop was copy some text onto the guest clipboard.

comment:7 Changed 5 years ago by michael

#4619 has been marked a duplicate of this.

comment:8 follow-up: ↓ 11 Changed 5 years ago by michael

I believe I may have fixed this problem. If you would like to try out the updated version of the Guest Additions you can download them via the link below. This is a test build of the future VirtualBox 3.0.6 Additions. Obligatory disclaimer  here.

 http://www.virtualbox.org/download/testcase/VBoxGuestAdditions-r51082.iso

comment:9 Changed 5 years ago by rct

I've experienced the problem of the host clipboard getting locked using a windows XPSP3 host with a linux guest (mandriva 2009.1, kde 4.2.4). Virtualbox version is 3.0.4. (Note: KDE's klipper seems to exacerbate the problem.)

Michael: Is the fix you've posted in VBoxGuestAdditions-r51082.iso likely to have any effect on window's hosts? Should I try it?

Thanks.

comment:10 Changed 5 years ago by michael

#4792 has been marked a duplicate of this ticket.

rct: if you are seeing similar issues on a Windows host then the fix might help there too. It should basically prevent the Linux or Solaris guest from permanently grabbing the host clipboard under certain circumstances.

comment:11 in reply to: ↑ 8 Changed 5 years ago by jnifoo

My original bug report was a duplicate of this one ( http://www.virtualbox.org/ticket/4619)

Returning from holidays, want to test this fix, but unfortunately, the link is not working now. Any new build to test ?

 http://www.virtualbox.org/download/testcase/VBoxGuestAdditions-r51082.iso

comment:12 Changed 5 years ago by michael

  • Version changed from VirtualBox 2.2.0 to VirtualBox 3.0.4

You could try out the 3.0.6 Beta version, see  http://forums.virtualbox.org/viewforum.php?f=15&start=0.

comment:13 Changed 5 years ago by jnifoo

Ok, just installed the 3.0.6 and the last guest addons, and the problem was solved. Thanks for this fix.

comment:14 Changed 5 years ago by michael

  • Summary changed from Using clipboard on guest locks host from using it. to Using clipboard on guest locks host from using it -> fixed in 3.0.6

Thanks for the feedback.

comment:15 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

comment:16 Changed 5 years ago by Julian Mehnle

It seems you managed to isolate and fix this very long standing bug that has been annoying me to death since at least VirtualBox 2.0 with a Linux 2.6.26 guest on a Mac OS X 10.5 host. Great job and thank you!

comment:17 Changed 4 years ago by Barron123

We were able to get a resolution to this problem from the  review of zend studio resource section.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use