VirtualBox

Ticket #407 (closed defect: fixed)

Opened 7 years ago

Last modified 6 years ago

Spurious NAK

Reported by: boget Owned by:
Priority: major Component: other
Version: VirtualBox 1.4.0 Keywords:
Cc: Guest type: other
Host type: other

Description

Thanks for your very nice product. I've installed on a Windows Host a Debian guest (2.6.-18 kernel version) in console mode (no X-Server installed). I notice everytime I lost the focus on the VirtualBox window the Linux's error messge : "atkbd.c : Spurious NAK on isa0060/serio0. Somme program might be trying access hardware directly".

I've upgraded to 1.4.0 version without changes. I've installed the guest additions on my Liux guest. I don't have this error message when I use the VBoxSDL program.

Do you have an idea ?

Thanks a lot for your help ...

Best regards

Change History

comment:1 Changed 7 years ago by seakayone

Same error message here. As well the focus loosing behavior is reproducable.

Installed VirtualBox 1.4.0 on Ubuntu 7.04.

Inside the box running debian etch kernel 2.6.14-4-686 #1 SMP

comment:2 Changed 7 years ago by alvarezp

Same here. It happens when the VM window loses the focus, which is a PITA when focus follows mouse is set. VBox 1.4.0 on Ubuntu 7.04.

comment:3 Changed 7 years ago by amazingrando

Having the same problem. Virtualbox 1.4.0 host with Debian 4.0 Etch as the guest OS.

comment:4 Changed 7 years ago by alvarezp

Found this:

 http://www.virtualbox.de/changeset/3767

About the comment "The real fix is to find a better way to prevent guests to interprete the KEYPRESS/KEYRELEASE event of a modifier key in that situation." -- Shouldn't the real fix be to only send key releases when keys are pressed?

comment:5 Changed 7 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

The problem is that a modifier key is probably pressed just before switching away from the VirtualBox window and released after the switch was done. If we don't do anything now, the guest things that the key is still pressed which is bad once we switch back to the VirtualBox window. But if we send the key release event of the modifier key, then certain guests might interpret the key press + key release event as an action (for instance pressing + releasing the ALT key activates the menu on some GUIs).

I will close this bug for now as we currently have no better solution and the bug should be much less annoying now.

comment:6 Changed 7 years ago by alvarezp

Fix confirmed in 1.5.0.

comment:7 Changed 6 years ago by leandro-baires

Hi, there is a workaround to prevent this message are displayed. You can configure kernel messages log level. Try this:

1) nano /etc/init.d/rc.local 2) Add this line (values are separated with a TAB character):

echo "4 4 1 7" > /proc/sys/kernel/printk

After reboot, kernel warning messages will not appear in console (but you can still query them using 'dmesg' command).

comment:8 Changed 6 years ago by leandro-baires

Correction:

File to edit is /etc/rc.local, no /etc/init.d/rc.local.

(problem still remains in 1.5.6)

comment:9 Changed 6 years ago by frank

If there is such a message in your Linux guest then only very seldom.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use