VirtualBox

Ticket #4063 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

Windows guest additons: access denied when saving to shared folders -> Fixed in 3.0.0

Reported by: d0b33 Owned by:
Priority: major Component: shared folders
Version: VirtualBox 2.2.2 Keywords: windows shared folders access denied
Cc: Guest type: Windows
Host type: Linux

Description

Hi I have windows guest addition 2.0.4 installed on XP sp3 and when I save files using Photoshop to a shared folder it works perfectly.

I recently tried a clean install with 2.1.4 and then 2.2.2 and the guest additions newer than 2.0.4 like 2.1.2 - 2.2.2 cannot save to a shared folder and I get the error message "drive not accessible."

The older additions don't have this bug.

Attachments

ubuntu_spec.txt Download (184.3 KB) - added by d0b33 5 years ago.
Ubuntu system info
not_accessible.jpg Download (141.8 KB) - added by d0b33 5 years ago.
Not accessible shared folder

Change History

comment:1 Changed 5 years ago by d0b33

Using Ubuntu Jaunty

comment:2 follow-up: ↓ 3 Changed 5 years ago by Murz

Confirm this on Ubuntu Jaunty AMD64 as host and WinXP SP2 as guest. At 2.1.x version of Virtualbox all works good, but after upgrade host to 2.2.2 I got an error in Photoshop CS3 when saving new file to the shared folder. Updating guest drivers from 2.1.x to 2.2.2 didn't help. If I try to create new file via Adobe Illustrator CS3 or another software, all saves without errors. And I can create folders/files in other software on the shared folders. I think that Phothoshop check rules or some else before saving... Saving files to virtual disk works good from photoshop.

comment:3 in reply to: ↑ 2 Changed 5 years ago by d0b33

Replying to Murz:

Confirm this on Ubuntu Jaunty AMD64 as host and WinXP SP2 as guest. At 2.1.x version of Virtualbox all works good, but after upgrade host to 2.2.2 I got an error in Photoshop CS3 when saving new file to the shared folder. Updating guest drivers from 2.1.x to 2.2.2 didn't help. If I try to create new file via Adobe Illustrator CS3 or another software, all saves without errors. And I can create folders/files in other software on the shared folders. I think that Phothoshop check rules or some else before saving... Saving files to virtual disk works good from photoshop.

There is a temporary fix, uninstall the latest guest additions and install the older additions like 2.0.X...

2.0.4 guest additions works for me.  http://download.virtualbox.org/virtualbox/2.0.4/VBoxGuestAdditions_2.0.4.iso

comment:4 Changed 5 years ago by guy_ad

Confirm this on Ubuntu Jaunty Intel host, WinXP SP2 guest. VirtualBox 2.2.2 with Guest Additions

 BeyondCompare and Eudora both have problems while trying to create temporary files in the current folder on a VirtualBox network_shared_folder.

BeyondCompare error message is more precise :
<<Cannot create file "Z:\xyz\BC39.tmp". Accès refusé>> (I use a French XP => Forbidden Access)

Same problem with access through network name : "\VBOXSVR\_am"
<<Cannot create file "\VBOXSVR\_am\xyz\BC39.tmp". Accès refusé>>

Of course I can create that file with Win32 Explorer or a Python script.

comment:5 Changed 5 years ago by guy_ad

And of course BeyondCompare and Eudora work fine on same network_shared_folder after I uninstalled Guest additions 2.2.2 and installed Guest additions 2.0.4

comment:6 Changed 5 years ago by masterz

I also confirm this bug on Ubuntu9.04 AMD and WinXP sp3 as guest, using PhotoshopCS4. I Use Virtualbox 2.2.0

When trying to save a file on the shared folder, Photoshop creates a temp file with the name "~ps1.tmp" This file is marked as 'read-only' and is 0 bytes in size. It might be the cause of the problem. Saving or creating files in the same directory with simple programs as paint or wordpad works ok.

comment:7 Changed 5 years ago by sunlover

  • Keywords windows shared folders access denied added; XP SP3 removed
  • Component changed from network to shared folders
  • Summary changed from Windows guest additons has network bug to Windows guest additons: access denied when saving to shared folders

comment:8 Changed 5 years ago by Murz

Confirm this bug on 2.2.4-4797 version too!

comment:9 follow-up: ↓ 11 Changed 5 years ago by sunlover

  • Status changed from new to closed
  • Resolution set to fixed
  • Summary changed from Windows guest additons: access denied when saving to shared folders to Windows guest additons: access denied when saving to shared folders -> Fixed in 3.0.0

This should be fixed in VirtualBox 3.0.0. Please reopen if the problem persists.

comment:10 Changed 5 years ago by d0b33

  • Status changed from closed to reopened
  • Resolution fixed deleted

Not totally fixed in 3.0, can't paste files in shared folders and "drive inaccessible" errors occur after browsing a shared directory.

Photoshop can save now though so it is partially fixed.

comment:11 in reply to: ↑ 9 Changed 5 years ago by d0b33

Replying to sunlover:

This should be fixed in VirtualBox 3.0.0. Please reopen if the problem persists.

Not totally fixed in 3.0, can't paste files in shared folders and "drive inaccessible" errors occur after browsing a shared directory.

Photoshop can save now though so it is partially fixed.

comment:12 follow-ups: ↓ 13 ↓ 14 Changed 5 years ago by sunlover

  • Status changed from reopened to closed
  • Resolution set to fixed

d0b33, could you provide more details? What do you mean with "paste files in shared folders"? Which application do you use to do this? Which application is used to browse the shared directory? Windows Explorer?

Anyway the original problem with "access denied" in Photoshop has been fixed, right?

And this "drive inaccessible" is a separate problem. Please create another ticket for it and post required details there. Thanks.

comment:13 in reply to: ↑ 12 Changed 5 years ago by d0b33

  • Status changed from closed to reopened
  • Resolution fixed deleted

Replying to sunlover:

d0b33, could you provide more details? What do you mean with "paste files in shared folders"? Which application do you use to do this? Which application is used to browse the shared directory? Windows Explorer?

Anyway the original problem with "access denied" in Photoshop has been fixed, right?

And this "drive inaccessible" is a separate problem. Please create another ticket for it and post required details there. Thanks.

I'll post more details shortly and a screen shot but if I copy a folder into a shared folder I can't paste it to make a duplicate.

Changed 5 years ago by d0b33

Ubuntu system info

comment:14 in reply to: ↑ 12 ; follow-up: ↓ 15 Changed 5 years ago by d0b33

Ok, I'm not getting the inaccessible error for some reason, but copy and paste is broken on XP for me..

I've attached my System spec but I guess this bug should be closed.

Replying to sunlover:

d0b33, could you provide more details? What do you mean with "paste files in shared folders"? Which application do you use to do this? Which application is used to browse the shared directory? Windows Explorer?

Anyway the original problem with "access denied" in Photoshop has been fixed, right?

And this "drive inaccessible" is a separate problem. Please create another ticket for it and post required details there. Thanks.

comment:15 in reply to: ↑ 14 Changed 5 years ago by d0b33

You can close this bug, my apologies it has been fixed.

Thank so much.

copy and paste is broken but this is another bug though.

Replying to d0b33:

Ok, I'm not getting the inaccessible error for some reason, but copy and paste is broken on XP for me..

I've attached my System spec but I guess this bug should be closed.

Replying to sunlover:

d0b33, could you provide more details? What do you mean with "paste files in shared folders"? Which application do you use to do this? Which application is used to browse the shared directory? Windows Explorer?

Anyway the original problem with "access denied" in Photoshop has been fixed, right?

And this "drive inaccessible" is a separate problem. Please create another ticket for it and post required details there. Thanks.

comment:16 follow-up: ↓ 17 Changed 5 years ago by sunlover

  • Status changed from reopened to closed
  • Resolution set to fixed

Changed 5 years ago by d0b33

Not accessible shared folder

comment:17 in reply to: ↑ 16 ; follow-up: ↓ 18 Changed 5 years ago by d0b33

Replying to sunlover: Attached a screenshot of the not accessible error, If I try to open an image with photoshop by clicking on it then the shared folder gives this error, after a while I can access the folder again but soon after this will happen again.

should I reopen this bug? I came across it now again.

comment:18 in reply to: ↑ 17 Changed 5 years ago by d0b33

Replying to d0b33:

Replying to sunlover: Attached a screenshot of the not accessible error, If I try to open an image with photoshop by clicking on it then the shared folder gives this error, after a while I can access the folder again but soon after this will happen again.

should I reopen this bug? I came across it now again.

Created a new ticket instead.  http://www.virtualbox.org/ticket/4382

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use