VirtualBox

Ticket #4061 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

VirusScan Enterprise 8.5+ Services

Reported by: hkim823 Owned by:
Priority: major Component: other
Version: VirtualBox 2.2.2 Keywords: McAfee, VirusScan, Framework Services,
Cc: Guest type: Windows
Host type: Mac OS X

Description

When running a x86 Windows XP guest in Leopard (no idea about Tiger), I cannot install McAfee VirusScan Enterprise. From version 8.5 and 8.7 with various patches, the installer freezes when it finishes copying files but trying to start the services needed, it freezes up. The mouse hard locks, nothing can be done in the guest. Powering off the guest and then starting it up again will show that the application is installed, but within a few moments, the guest will full lock up, mouse frozen. I suspect the key is the services that McAfee is trying to start on in Windows and something about VirtualBox locking it up. I've tried it with XP SP2, XP SP3.

Change History

comment:1 Changed 5 years ago by hkim823

Tried to do the same thing for Windows 7 RC1 and McAfee VirusScan Enterprise 8.7 which is listed as compatible. It hung on installation at the same spot.

comment:2 Changed 5 years ago by nadim

I'm also having the same problem...McAfee VirusScan Enterprise 8.5i on a Windows XP SP3 VM locks up the VM on install (status: "Starting services"). Note that this bug is rather difficult to recover from as well, as the VM is unusable after this point...restarting the VM just causes it to lock up on startup. I was able to work around this problem by bringing up the Windows instance in safe mode, then deleting the folder where McAfee was partially installed (the uninstaller doesn't work), or, rather, all but two .dlls that don't seem to be able to be deleted.

comment:3 Changed 5 years ago by nadim

Also, note that this bug seems independent of host O/S. I have reproduced it with two separate guest instances of WinXP running under Ubuntu (9.04, amd64) as the host O/S, and also under Windows Vista (Home Premium, SP1) as the host O/S.

comment:4 Changed 5 years ago by nadim

Verified that this problem still occurs with VirtualBox 2.2.4.

comment:5 Changed 5 years ago by hkim823

Fixed in VirtualBox 3.0.2, possibly earlier versions of VirtualBox 3

comment:6 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

Thanks for the feedback.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use