VirtualBox

Ticket #4050 (closed defect: worksforme)

Opened 5 years ago

Last modified 5 years ago

VRDP does not follow RDP client resolution hint

Reported by: avok00 Owned by:
Priority: major Component: RDP
Version: VirtualBox 2.2.2 Keywords: VRDP, resolution
Cc: Guest type: Windows
Host type: Windows

Description

Using Vbox 2.2.2 on Windows Vista Business 64 SP1 - guest is Windows XP SP3

When using remote desktop to the any guest OS using VBox built in VRDP the resolution is only 800/600 and cannot be changed up. I tried settin RDP connection to 1024/768 (that I need) or full screen - same thing. The guest OS apears in little square with big black space around it. This started since I installed 2.2.2, I didn't have this problem in 2.2.0. I have many Windows XP guests, one Vista, latest guest additions installed, all show same way.

The only way to have Vbox VRDP window full screen is to set the partucular guest OS window to Full Screen in the host OS (Ctrl + F) and then to connect via VRDP

When I unininstalled the guest additions, I was able to set 1024/768 resolution within the guest OS and use it with remote desktop. But not having guest additions is not very good. My mouse is very slow and going through VRDP in addition to slow the cursor is double!

When guest additions are installed the video driver won't allow me to set resolution higher then 800 / 600!

I looked at the Guest OS Virtual box log. It has the following line:

125:01:05.524 VMMDev::SetVideoModeHint: got a video mode hint (1024x768x0) at 0

This is the resolution set in my RDP client. But VRDP server obviously chooses not to follow the hint. Not entry about that in the log.

Attachments

VBox.log Download (75.1 KB) - added by avok00 5 years ago.
This is the log from my last session. You can see this hint thing in the last entries.

Change History

Changed 5 years ago by avok00

This is the log from my last session. You can see this hint thing in the last entries.

comment:1 Changed 5 years ago by sunlover

The problem is related to the guest additions. Additions should process the setVideoModeHint request and change the guest resolution. The VRDP server tells them to do so, but they did not react according to your log. Also you wrote: "When guest additions are installed the video driver won't allow me to set resolution higher then 800 / 600!" This seems to be some installation problem with the guest additions. Could you please try to reinstall them? BTW, you reported this for VBox 2.2.2, please try version 2.2.4 (or 3.0.0). Thanks.

comment:2 Changed 5 years ago by frank

For the 800x600 problem please have a look at section 9.13 (or look  here).

comment:3 Changed 5 years ago by avok00

Problem solved! Thanks frank!

comment:4 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to worksforme

Thx for the feedback.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use