VirtualBox

Ticket #4040 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

VirtualBox becomes Zombie process, requiring Host hard-reset -> fixed in SVN/3.0.0 beta 2

Reported by: Technologov Owned by:
Priority: blocker Component: VMM
Version: VirtualBox 2.2.2 Keywords:
Cc: Guest type: other
Host type: Windows

Description (last modified by frank) (diff)

When installing several VMs in parallel, VBox processes may stuck.

Symptoms:

When this happens, all VBox processes becoming zombie processes without ability to get them killed. Windows Task manager did not help -- it refuses to kill VBox processes. I could not soft-restart or soft-shutdown host Windows either. Had to do hard-reset. When I press "kill task" in Task manager, the VM's GUI window disappears from Windows Desktop, but process continues to exist in Task Manager. (which I interpret as zombie process) Host OS & all apps continue to run, but becoming extremely slow, especially on Disk I/O operations.

Host: Windows XP SP2, Intel Core 2 Q6600 CPU, VBox 2.2.2. (VT-x enabled)

It happened with the following combos: (two VMs installed in parallel)

  • Win2000 + Win 7 RC1 (32-bit)
  • Fedora 9 and 10 (both 32-bit)

I don't see anything strange in VBox logs. But my understanding of them is imperfect.

-Technologov, 18.5.2009.

Attachments

logs.zip Download (76.8 KB) - added by Technologov 5 years ago.
VBox logs on Win7, F9, and F10.
Vbox64_VmFreezeLogs.zip Download (26.8 KB) - added by vboxwebatsf 5 years ago.
Logs of VMs when all of them froze.

Change History

Changed 5 years ago by Technologov

VBox logs on Win7, F9, and F10.

Changed 5 years ago by vboxwebatsf

Logs of VMs when all of them froze.

comment:1 Changed 5 years ago by vboxwebatsf

Yeah I've had this problem as well. I was using Windows 7 x64 as a host and it droped out on me when booting Windows 7 (guest) and Windows XP Home (guest) at the same time and I had a session of OpenSuSE Linux 11.1 running.

comment:2 Changed 5 years ago by pathomas

Windows Vista 32 x-VT, PAE enabled, This also sometimes happens on a VM restart, screen becomes unresponsive and CPU utilization jumps to 100% on VirtualBox.exe. also if "VBoxManage list" or some other operation is run that process will hang. restarting VBoxSVC.exe will stop VBoxManage from hanging but restarting the zombie VM results in a sharing violation.

comment:3 Changed 5 years ago by Technologov

I have reproduced this problem on Windows 7 RC1, 64-bit host on same hardware.

Host: Windows 7 RC1, 64-bit, Intel Core 2 Q6600 CPU, VBox 2.2.2. (VT-x enabled)

-Technologov

comment:4 Changed 5 years ago by sander

Same problem here. host: Windows XP SP3, Guest OS was Windows 2008 SP2 32bit.

Only solution is to reboot the whole host to clear out those zombie processes.

comment:5 Changed 5 years ago by vboxwebatsf

I've used VirtualBox on 32 and 64 mode and my experience is that 64 bit experiences this issue quite regularly while 32 bit is intermittent. It also seems to happen most when 2 VMs are running at the same time and usually starts off when 1 of the VMs tries to start and the small startup progress dialog appears but does not move. The VMs that this happens to me on had these things in common: Bridged networking on the same NIC. Same shared folder configuration.

comment:6 Changed 5 years ago by frank

  • Description modified (diff)

Hmm, in vboxwebatsf's log I saw one VM using a bridged connection but I don't see any network configuration in Technologov's log. Is there any other evidence that bridged networking is involved?

comment:7 Changed 5 years ago by Technologov

frank: I think bridging is not involved. I had this problem using NAT, and without guest additions.

What is involved is running several VMs in parallel, especially with heavy load, like installing guest OSes.

-Technologov

comment:8 Changed 5 years ago by frank

But only on Windows hosts, correct?

comment:9 Changed 5 years ago by Technologov

Due to lack of time, I have not tested on Linux hosts.

-Technologov

comment:10 Changed 5 years ago by naty81

This issue continues in the version 2.2.4.

comment:11 Changed 5 years ago by ddn

if i start more than 2 VBox VMs i had this too :(

this is from very older builds of VBox (2.1.x if i remember correct)

comment:12 Changed 5 years ago by hansenc

Kinda having the same issue, only difference is that my host doesn't freeze. I do have to reboot to free the virtualbox process, i cannot kill it.

Windows 7

comment:13 Changed 5 years ago by hansenc

Just relized this is the same issue, i have to hard reboot my laptop to recover.

Windows 7 x64 RC

Hosts I have had running are- Fedora 11 x64 Windows 7 x64 Windows 2008 x64 Windows Vista x64

comment:14 Changed 5 years ago by xcleric42

Having the same issue on two hosts: Win7 RC1 32bit, and XP SP3 32 bit. 4 guests on the XP host are all XP SP3 (all using bridge networking on one NIC), guests on Win7 host are mostly linux live cd's. Occasionally happens when starting or restarting a VM with another VM already running. Seems pretty random, as it survived patch tuesdays simultaneous restarts last week (XP host), but froze with a shutdown command yesterday. Also some guests are not rebooting properly, ie getting stuck on a screen with vertical green lines on it. Had this a lot in version 1, a lot less in 2.1, but noticeably more now.

IO APIC: disabled VT-x/AMD-V: disabled Nested Paging: disabled PAE/NX: disabled

3d: enabled on some

comment:15 Changed 5 years ago by patrick

Having the same issue running with host XP_PRO_SP3. I'm running a guest XP_PRO_SP3 and a guest with CentOS-4.7-i386. This last time the processes went nuts when I rebooted the centos guest. Both guests suddenly became unresponsive. I've tried killing them using ProcessExplorer but both processes still seem to be running, one at 50%. I'm running VirtualBox 2.2.4 r47978. Does anyone have an idea of how to get kill these processes so I don't have to reboot? I have a Dell Precision T3400.

comment:16 Changed 5 years ago by fapostolo

I have the same problem, really annoying because i have to much stuff open in host to be comfortable restarting, besides this new big problem, Virtual box is 5 stars.

I have windows 7 64 bit with 12gb ram, using defaults with 3d acceleration.

My problem is i didn't had problems killing processes since bloody horrible windows 95.

pardon my English.

comment:17 Changed 5 years ago by fapostolo

I TRY TO KILL Handles and much more, i even "disconnected" the drive source ,omg i give up and go restart

comment:18 Changed 5 years ago by frank

We get such zombie process under rare circumstances as well and trying to find the cause of this problem.

comment:19 Changed 5 years ago by hansenc

Seems to be better with the Beta of Virtual box but still happens.

comment:20 Changed 5 years ago by fapostolo

yes it looks pretty complicaded, i surely cant help even being a programmer i dont have knowledge for this. Sorry if my comments sounded bad, u guys do a extraordinary job,

well append to me twice, one yesterday and one today:

I allways had 2 machines opened, yesterday was 1 windows 7 and 1 win server 2008 today i was installing ubunto and had 1 of the windows 7 opened. I'm using a corei7 920, mb gigabyte ud4, 12gb ram, 1T WD FALS.

Like i said Good Work.

comment:21 Changed 5 years ago by fapostolo

gfx zoltec 9600, windows 7 is host and i have "incompatible" G15 keyboard and g9 mouse drivers installed.

comment:22 Changed 5 years ago by tarzanek

Same problem here Vista 64bit SP2 as host and OpenSolaris 2009/06 as guest it seems it gets easy to reproduce when you have 3.x and guest additions installed, or you just installed them and do the first boot after ... (VirtualBox.exe "hangs" just after trying to boot X)

comment:23 Changed 5 years ago by sandervl73

Reproduced here. We're close to a fix.

comment:24 Changed 5 years ago by fapostolo

LOVELY, actual i think it i was also installing guest additions at least another time i didnt remember. i have read about 3.x and beta but i didnt find then in downloads, i should look better lol or its in another area?

comment:25 Changed 5 years ago by Technologov

sandervl73: I'm glad to hear that; What causes the problem ?

-Technologov

comment:26 Changed 5 years ago by sandervl73

  • Summary changed from VirtualBox becomes Zombie process, requiring Host hard-reset to VirtualBox becomes Zombie process, requiring Host hard-reset -> fixed in SVN/3.0.0 beta 2

comment:27 Changed 5 years ago by sandervl73

Technologov: kind of too detailed and technical to discuss here. A nasty bug with bad consequences.

comment:28 Changed 5 years ago by hansenc

YAY. Thanks.

comment:29 Changed 5 years ago by hansenc

When will Beta2 be released?

comment:30 Changed 5 years ago by fapostolo

Many Thanks, is there a precompiled version for windows in SVN? i dont know if its java or c++ , i can only compile C in Linux lol... ill check tomorrow at work.

Any Way Many Thanks!

comment:31 Changed 5 years ago by sandervl73

3.0.0 Beta 2 is scheduled to be released later today. Watch the beta forum on  http://forums.virtualbox.org

comment:32 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use