VirtualBox

Ticket #3997 (closed defect: duplicate)

Opened 5 years ago

Last modified 5 years ago

Unable to add .vhd file into Virtual Media Manager

Reported by: chris.senior Owned by:
Priority: major Component: virtual disk
Version: VirtualBox 2.2.2 Keywords: VHD
Cc: Guest type: Windows
Host type: Windows

Description

I have a .vhd file already added to my virtual media manager. A while ago I copied the .vhd file and installed different software onto the guest OS (using MS Virtual PC). So now I have two .vhd files with more or less the same OS, one with different applications installed.

If I try to add the second .vhd file (originally a copy of the first, now very different) I get an error from Virtual Box: "Failed to open the hard disk 'X:\ ... a.vhd'. Cannot register the hard disk with UUID {...} because a hard disk 'X:\ ... b.vhd' with UUID {...} already exists in the media registry (...xml)"

Result Code: E_INVALIDARG (0x80070057) Component: VirtualBox Interface: IVirtualBox {779264f4-65ed-48ed-be39-518ca549e296}

Change History

comment:1 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Actually this is a duplicate of #3443. If you copy a .vhd image you have to change the UUID of that file (which currently doesn't work).

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use