VirtualBox

Ticket #3956 (new defect)

Opened 5 years ago

Last modified 3 years ago

Vista x64 host, E_NOINTERFACE error (0x80004002)

Reported by: Atcom Owned by:
Priority: major Component: installer
Version: VirtualBox 2.2.2 Keywords:
Cc: Guest type: other
Host type: Windows

Description

I installed Virtual Box 2.2.2 on Vista x64, with administrator privileges. After installation process, when i start the application the following error dialog appears: Failed to create the VirtualBox COM object. Callee RC: E_NOINTERFACE (0x80004002). I tried manually start VBoxSVC.exe, reregister it and reinstall the VirtualBox with disabled NOD32 4.0, but not solved the problem.

Attachments

logs.rar Download (49.4 KB) - added by Atcom 5 years ago.
setupapi.app.log Download (26.8 KB) - added by Peter0309 4 years ago.
setupapi.dev.log Download (45.0 KB) - added by Peter0309 4 years ago.
err.txt Download (371 bytes) - added by fuziko 3 years ago.
my error

Change History

comment:1 Changed 5 years ago by pentagonik

Please try installing VBox again, but before that please read the article at  http://www.virtualbox.org/wiki/MSI_Logging on how to enable the installer logs. After the install failed attach the logs to this defect.

Changed 5 years ago by Atcom

comment:2 follow-ups: ↓ 3 ↓ 7 Changed 5 years ago by frank

Still relevant?

comment:3 in reply to: ↑ 2 Changed 5 years ago by Atcom

Yes, still relevant in version 3.0.2 too.

Changed 4 years ago by Peter0309

Changed 4 years ago by Peter0309

comment:4 Changed 4 years ago by Peter0309

I have the same problem running VirtualBox-3.2.4-62467-Win under Windows7 (32-bit). Is there any solution ?

comment:5 Changed 4 years ago by f0127

Same problem running VirtualBox 3.2.8 under XP SP3. I can run VirtualBox after unistalling and reinstalling (repair does not work) once. After closing VirtualBox and trying to start it again I get the error.

comment:6 Changed 4 years ago by petrjung

Same problem running VirtualBox 3.2.8 under XP x86 SP3. After installation successful, and running I had the registry problem. I must restore back to saved restore point and from this time the VirtualBox get the E_NOINTERFACE error (0x80004002) error.

There is probably problem with miniport, but HW page will not show any warnings. Full reinstalation and does not work. Any advice?

comment:7 in reply to: ↑ 2 Changed 4 years ago by petrjung

Replying to frank:

Still relevant?

I had this problem and I have solved it. The McAfee antivirus restric some registry permissions on creating the COM+ object. I was not even able to reinstall the COM+, bus as an Administrator I could. SO refresh the permissions and CURRENT_USER to root one. Petr

Changed 3 years ago by fuziko

my error

comment:8 Changed 3 years ago by fuziko

Hi i solve this error ! I get someday error like  this.

I i think a little and try to check my disk space, and new virtual machine that i want to clone was bigger than my free space .. I free some space and they start work normal .. It's amazing, but it's true. Have fun !

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use