VirtualBox

Ticket #3952 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

Vbox 2.2.2 install causes all network cards to be deleted from Vista, driver reinstallation fails, only solution : uninstall Vbox

Reported by: cuby Owned by:
Priority: major Component: installer
Version: VirtualBox 2.2.2 Keywords: vista, intel wifi card
Cc: Guest type: Linux
Host type: Windows

Description

Installed version 2.2.2 on Vista 32bits OS with an Intel Wireless WiFi Link 4965AGN Card.

Installation goes fine, network disconnects, reconnects. One can use the network without any trouble as long as the PC is on.

After reboot, wifi card seems to have been totally wiped off the system. Only Vbox's Host-Only Network is left & bluetooth works.

Tried :

  • Deleteing the Vbox Host Only things
  • Reinstalling Driver
  • Uninstalling Driver & Reinstalling Driver
  • Adding my wifi card manually & Installing driver

The ONLY solution i've found is to uninstall Vbox 2.2.2....

This is really critical since old VDI disks are now "updated" to 2.2.2 format and one can't use 2.2.2 because it busts the host network.

Change History

comment:1 Changed 5 years ago by misha

Am I correct that your wifi card is not displayed in device manager? Do you see any additional devices displayed if you select menu "View"->"Show Hidden Devices"?
What VBox version did you have installed before? Does this issue appear when you re-install the older version of VBox again (note that you need to uninstall the 2.2.2 before for the downgrade to work correctly)?
Did you update (installed "on top" of the previous version) or uninstalled the previous version before installing the 2.2.2?

Could you also try to do the following:

  1. Enable  msi & setupapi loging, try to install the 2.2.2 and post here msi & setupapi logs for your install
  2. after the install in case you see this problem again, open properties for one of your network connections (e.g. for the host-only one), select "VirtualBox Bridged Networking Driver" and click Uninstall. -> Does this solve the problem ? If yes it would be good to have setupapi log for this action as well, so just keep setupapi logging enabled when doing this and post me the setupapi log files after that.

comment:2 Changed 5 years ago by cuby

While searching for a solution, I couldn't see my wifi card in the network devices but i didn't think of looking for hidden devices, sorry.

I tried to delete the VirtualBox Host Only device but the "Delete" option was disabled.

Here is a quick summary of what I did :

At first I updated 2.2.2 over 2.1.4 and the problem occurred.

I then downgraded to 2.1.4 with success. I tried full uninstall and then reinstall 2.2.2, same problem.

I reformatted a few days ago and installed 2.2.2 on a clean system, same problem.

This morning i did full uninstall and resintall without the networking option. Vbox & my wifi both work fine now.

For me the problem is solved as I don't use the new networking feature but this must be bothering other users.

Thanks for your quick answer !

comment:3 Changed 4 years ago by pentagonik

  • Status changed from new to closed
  • Resolution set to fixed

Should not appear on latest VBox version anymore, closing.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use