VirtualBox

Ticket #3910 (closed defect: worksforme)

Opened 5 years ago

Last modified 5 years ago

VT-x/AMD-V options are disabled when the after suspend on host

Reported by: graysky Owned by:
Priority: critical Component: VMM
Version: VirtualBox 2.2.2 Keywords: suspend TV-x
Cc: Guest type: Linux
Host type: Linux

Description

When I suspend my HOST box and then awaken it again, VBox doesn't run my 64-bit guest VM and gives this error:

VT-x/AMD-V hardware acceleration has been enabled, but is not operational. Your 64-bit guest will fail to detect a 64-bit CPU and will not be able to boot. Please ensure that you have enabled VT-x/AMD-V properly in the BIOS of your host computer.

I rebooted and entered my BIOS. All my virtualization options are set to enable.

The only way to fix this is to cold boot the system (i.e. totally power down then turn on). If I just reboot, the problem is not solved and the 64-bit VM does not work giving that error.

I have confirmed this on two Linux Hosts (Ubuntu Intrepid amd64 and Arch x86_64) and on a Windows Host (Windows XP Pro 64-bit edition SP2). My VM's in all three cases were also a WinXP 64-bit VM and an Arch Linux 64-bit VM.

Attachments

VBox.log Download (48.2 KB) - added by graysky 5 years ago.

Change History

Changed 5 years ago by graysky

comment:1 Changed 5 years ago by graysky

Sorry guys, the error I quoted above was from version 2.2.0 of VBox. I have since updated to version 2.2.2 and the same problem is present w/ v2.2.2 but the text in the error is a little different, it reads simply:

Failed to start the virtual machine Arch64.  VT-x is not available. (VERR_VMX_NO_VMX).  Unknown error creating VM (VERR_VMX_NOVMX).


Result Code:
NS_ERROR_FAILURE (0x80004005)
Component: 
Console
Interface: 

comment:2 Changed 5 years ago by graysky

Result Code: NS_ERROR_FAILURE (0x80004005)
Component: Console
Interface: IConsole 9511bc54-15ee-4ddf-808e-472aba03809c

comment:3 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to worksforme

Try to find an upgrade for your BIOS. It messes up VT-x after resume. Not a VirtualBox bug.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use