VirtualBox

Ticket #3906 (closed defect: duplicate)

Opened 5 years ago

Last modified 5 years ago

wxp guest, ubuntu 9.04 host, network in guest doesnt work when network in host turned back on

Reported by: whorush Owned by:
Priority: major Component: network/NAT
Version: VirtualBox 2.2.2 Keywords: PCnet-FAST III (NAT)
Cc: Guest type: Windows
Host type: Linux

Description

this one is a bit tricky, but i've reproduced it a few times. its hard to reproduce, because i think the host network must be down a long time before its turned back on, a minute or two doesn't work. 20 hours does. i'm not sure where the threshold in between is.

host ubuntu 9.04 amd64, NIC in AMD 780G chipset, ext4

guest plain vanilla wxp 32bit

network PCnet-FAST III (NAT)

this whole thing worked fine until i upgraded from ubuntu 8.10 amd64 on the same computer. at the same time i think i also upgraded vbox? not sure.

here's the bug.

i leave the vm running all the time. but i turn the network on and off on the host. when i turn the network back on after being off for A WHILE (not sure what the threshold is), then the vm can't access the network. i try software stuff inside windows, like repair connection, or disable then enable, and it doesn't work. i have to restart the windows machine. mabye if i wait another long while it will find the network, but i haven't tried. either way its still a bug, thats making me nuts :-). i'm going to try downgrading.

Change History

comment:1 Changed 5 years ago by whorush

ok, i downgraded form 2.2.2 to 2.1.4 and now it works :-), so that means it probably wasn't the ubuntu upgrade, but instead some bug in 2.2.2.

comment:2 Changed 5 years ago by frank

  • Priority changed from blocker to major

How did you check the network access? Is it possible that the connection was still alive but only the name server was not accessible?

comment:3 Changed 5 years ago by Hachiman

  • Status changed from new to closed
  • Resolution set to duplicate

duplicate of #3847

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use