VirtualBox

Ticket #3895 (closed defect: duplicate)

Opened 5 years ago

Last modified 4 years ago

USB Auto detection does not work

Reported by: Perryg Owned by:
Priority: major Component: USB
Version: VirtualBox 2.2.2 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description

This has been an issue since at least version 2.14. Steps below on how I must make this work. Any other way fails and USB device is not available even to the host once VBox tries and fails to load it. ( This produces a VBox GUI failure and shuts it down). To get the device to work again in the host I must completely shut down VBox (sometimes need to kill Vboxsvc in the process manager) and unplug the device and plug it back in until it is recognized. Once I have completed the steps below I can reboot the guest and it works until I reboot the host and then I must do as below or it will not work. Reboot host

  1. Open the VBox GUI.
  1. Open settings to the guest.
  1. Under the USB section remove the check mark from the (+) active filter, and only leave the (.) blank filter. This takes 2 to 3 times before the active filter actually changes. Once I see that the change has taken I can go to the next step. I must have both filters in the settings to get it to work. Removing the blank filter will cause it to fail.
  1. Boot the guest.
  1. Remove the USB device from the host and plug back in for the guest to get focus and install the USB device.
  1. Shut down the guest and open the settings for the guest where I can put the check mark back in the second filter (+).
  1. Reboot the guest and it auto detects the USB device and removes it from the host and loads it into the guest.

If I do not reboot the host I can then reboot the guest as many times as I want and it auto loads the USB device as it should. Once I reboot the host I must go through these actions again to be able to use the USB device.

Attachments

Logs.zip Download (88.2 KB) - added by Perryg 5 years ago.
Sequence (8) log files as they progressed after the host reboot
USB.jpg Download (26.0 KB) - added by Perryg 5 years ago.
USB Error
VBoxUSB05142009.zip Download (169.1 KB) - added by Perryg 5 years ago.
USBlist.txt Download (4.7 KB) - added by Perryg 5 years ago.
Requested USBlist 05-18-2009

Change History

Changed 5 years ago by Perryg

Sequence (8) log files as they progressed after the host reboot

comment:1 Changed 5 years ago by Perryg

This just gets better. When the host is rebooted. and I forget to turn off the filters (USB and Serial) Vbox crashes. It kills all usb devices until I remove them (MS USB safe removal) then unplug and replug them. Sometimes it hangs as in a panic and will not allow me to stop the process. I must reboot the machine and sometimes I must hit the reset button to get it to power down. I do not see how to elevate this to critical or I would.

comment:2 Changed 5 years ago by Perryg

Some more testing that I hope leads to the resolve: I find that upon reboot the device drivers are not loaded for the USB device and when you start the guest with the (+) filter, Windows tries to load the device while the guest is starting. This is when the VBoxsvc and the Vbox GUI fail. If however I do the reboot sequence as stated above the device driver installs and loads properly. then I can turn on the (+) filter and it works until the next time I reboot the Host. I believe it is because the device driver is already loaded that is allowing this to work.

comment:3 Changed 5 years ago by Perryg

It's been two weeks. Anything going on with this? If this is the way it is supposed to work then you can just tell me and I will go away? No problem.

comment:4 Changed 5 years ago by michaln

Is this something that worked for you in versions prior to 2.1.4, or do you just mean to say that the problem exists in 2.1.4 and later versions, but you haven't tried the earlier ones?

comment:5 Changed 5 years ago by Perryg

It has never worked as stated. I finally figured out a work around as stated above but this is the only way I can get it to work.

comment:6 Changed 5 years ago by frank

The first sentence in the description was that it did not work for you at least since 2.1.4. Therefore the request for clarification. There are known issues on Windows hosts and fixing them is quite difficult. Passing a USB device to the guest usually works better for me when I don't create a filter but pass it through the devices menu.

comment:7 Changed 5 years ago by Perryg

OK sorry about the confusion. So if I do not create a filter how do I pass it through the device menu?

comment:8 Changed 5 years ago by frank

Even if you don't created a filter the USB device should be visible in the Devices / USB menu. Just selecting such a device should pass the device to the guest, selecting it again should remove it from the guest. The filter is used if an USB device should be automatically passed to the guest on VM startup while the Devices menu is used to temporarily pass a device to the guest.

Changed 5 years ago by Perryg

USB Error

comment:9 Changed 5 years ago by Perryg

When doing that they are in fact visible but selecting them creates VBox error - device is busy. attachment USB.jpg enclosed

Changed 5 years ago by Perryg

comment:10 Changed 5 years ago by Perryg

I am sending a zip file of 4 screen shots of the progress of using the USB from a complete reboot of the host. 1st file BeforeVB-start shows no usb driver loaded. 2nd file AfterStart-VB.ipg.jpg shows the 3 devices, still no driver loaded in DM. 3rd file ClickonUSB.jpg shows USB device loaded in DM and VBox error. 4th file VBoxSVCexe-Gone.jpg shows the service is gone from the task manager. Both the VB main file and the one for the VN are still loaded boot can not function. After closing down all of the VBox programs and then starting them they work but when I click on the USB device as you suggest it produces the results in my last post.

comment:11 Changed 5 years ago by Perryg

Is there anything else I can send/tell you about this? If it is not possible for this to work I can live with it, but if it can be achieved I would really like to know what I am doing wrong. You state there are known issues (Windows host) and that they are difficult to fix. Can you elaborate on this? Maybe I can figure out what I need to do with more information.

comment:12 Changed 5 years ago by michaln

There are currently some bugs in the VirtualBox USB device capturing on Windows, unfortunately.

Could you please try running 'VBoxManage list usbhost' at various stages and attach the output here? It might help us to see how the status changes (or doesn't when it should).

Changed 5 years ago by Perryg

Requested USBlist 05-18-2009

comment:13 Changed 5 years ago by Perryg

USBlist.txt attachment added.

Question; Is there some way that I can pre-load the VBox USB device driver before using the program? I want to test to see if this is being caused because it is not loaded before the program calls it.

comment:14 Changed 5 years ago by Perryg

I assume that no news in this case is not good news. Unfortunately I do not have any more time to invest in this unless someone somewhere can work with me to see what the problem is. I guess you can close this ticket and mark it

Closed with no resolution available.

comment:15 Changed 5 years ago by BradOlson

I have these problems as well.

comment:16 Changed 4 years ago by Perryg

This ticket can be closed AFAIAC Problem resolved in Ticket #3758

comment:17 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use