VirtualBox

Ticket #3890 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

vbox hangs when trying to import virtual appliance

Reported by: FrankVanDamme Owned by:
Priority: major Component: other
Version: VirtualBox 2.2.2 Keywords:
Cc: Guest type: other
Host type: Mac OS X

Description

I am running virtualbox on OS X. When selecting the menu option "import appliance #I", the program stops responding and must be killed.

I don't have any more information than that, if needed please tell me how to collect more.

Change History

comment:1 Changed 5 years ago by hwinkler

I have a similar issue. Host Mac OS X 10.5.6, MacBook Pro5,1 2.4 GHz, VB 2.2.2 r46594

Importing an appliance generated on Ubuntu host containing an Ubuntu guest. The appliance has two vmdks. During import it appears to read one vmdk. it might be reaching the end of that one and transiotioning to the next one? The progress bar hangs after about 10 minutes of progress on the first vmdk.

I can press Cancel to close the import progress dialog. But subsequently if I try to open File/Virtual Media Manager, there's no response an VB freezes and the only way to exit is to kill the process.

There are no log files generated.

Below is a thread dump generated by killing VB after tryng to open Vitual Media Manager as above:

Process: VirtualBox [625] Path: /Applications/VirtualBox.app/Contents/MacOS/VirtualBox

ADDRESS BINARY 00001000 /Applications/VirtualBox.app/Contents/MacOS/VirtualBox 00018000 /Applications/VirtualBox.app/Contents/MacOS/VBoxREM.dylib 00033000 /Applications/VirtualBox.app/Contents/MacOS/VBoxDDU.dylib 000f6000 /Applications/VirtualBox.app/Contents/MacOS/components/VBoxSVCM.dylib 00300000 /Applications/VirtualBox.app/Contents/MacOS/VBoxRT.dylib 003a1000 /Applications/VirtualBox.app/Contents/MacOS/VirtualBox.dylib 00750000 /Applications/VirtualBox.app/Contents/MacOS/components/VBoxXPCOMIPCC.dylib 007a0000 /Library/InputManagers/GearsEnabler/GearsEnabler.bundle/Contents/MacOS/GearsEnabler 007a8000 /System/Library/CoreServices/Encodings/libSimplifiedChineseConverter.dylib 01000000 /Applications/VirtualBox.app/Contents/Frameworks/QtCoreVBox.framework/Versions/4/QtCoreVBox 01240000 /Applications/VirtualBox.app/Contents/Frameworks/QtGuiVBox.framework/Versions/4/QtGuiVBox 01bf6000 /Applications/VirtualBox.app/Contents/Frameworks/QtNetworkVBox.framework/Versions/4/QtNetworkVBox 01d0e000 /Applications/VirtualBox.app/Contents/MacOS/VBoxVMM.dylib 01e72000 /Applications/VirtualBox.app/Contents/MacOS/VBoxXPCOM.dylib 12e97000 /System/Library/CoreServices/Encodings/libTraditionalChineseConverter.dylib 14f7f000 /Library/InputManagers/Safari140/Safari140.bundle/Contents/MacOS/Safari140 153a8000 /System/Library/CoreServices/RawCamera.bundle/Contents/MacOS/RawCamera 168e2000 /System/Library/PrivateFrameworks/URLMount.framework/URLMount 1f7f8000 /System/Library/Filesystems/URLMount/smb.URLMounter/Contents/MacOS/smb 1f84e000 /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/CoreGraphics.framework/Versions/A/Resources/libCGXCoreImage.A.dylib ba900000 /System/Library/CoreServices/Encodings/libJapaneseConverter.dylib bab00000 /System/Library/CoreServices/Encodings/libKoreanConverter.dylib

Thread id: 906fb58 User stack:

116 start + 41 (in VirtualBox) [0x2449]

116 start + 216 (in VirtualBox) [0x2522]

116 _main + 65 (in VirtualBox) [0x2be1]

116 _SUPR3HardenedMain + 540 (in VirtualBox) [0x374c]

116 _TrustedMain + 2707 (in VirtualBox.dylib) [0x3a3fe3]

116 ZN16QCoreApplication4execEv + 161 (in QtCoreVBox) [0x1103301]

116 ZN10QEventLoop4execE6QFlagsINS_17ProcessEventsFlagEE + 157 (in QtCoreVBox) [0x10ff36d]

116 ZN10QEventLoop13processEventsE6QFlagsINS_17ProcessEventsFlagEE + 65 (in QtCoreVBox) [0x10ff2a1]

116 ZN19QEventDispatcherMac13processEventsE6QFlagsIN10QEventLoop17ProcessEventsFlagEE + 658 (in QtGuiVBox) [0x12b3a42]

116 Z17qt_mac_send_event6QFlagsIN10QEventLoop17ProcessEventsFlagEEP14OpaqueEventRefP15OpaqueWindowPtr + 97 (in QtGuiVBox) [0x12a5401]

116 _SendEventToEventTarget + 52 (in HIToolbox) [0x9345aed2]

116 Z30SendEventToEventTargetInternalP14OpaqueEventRefP20OpaqueEventTargetRefP14HandlerCallRec + 405 (in HIToolbox) [0x9343e57d]

116 Z23DispatchEventToHandlersP14EventTargetRecP14OpaqueEventRefP14HandlerCallRec + 2134 (in HIToolbox) [0x9343f4fc]

116 Z29ToolboxEventDispatcherHandlerP25OpaqueEventHandlerCallRefP14OpaqueEventRefPv + 2579 (in HIToolbox) [0x9346d603]

116 _SendEventToEventTarget + 52 (in HIToolbox) [0x9345aed2]

116 Z30SendEventToEventTargetInternalP14OpaqueEventRefP20OpaqueEventTargetRefP14HandlerCallRec + 405 (in HIToolbox) [0x9343e57d]

116 Z23DispatchEventToHandlersP14EventTargetRecP14OpaqueEventRefP14HandlerCallRec + 1181 (in HIToolbox) [0x9343f143]

116 ZN19QApplicationPrivate20globalEventProcessorEP25OpaqueEventHandlerCallRefP14OpaqueEventRefPv + 13186 (in QtGuiVBox) [0x12ac2f2]

116 _MenuSelect + 104 (in HIToolbox) [0x93521188]

116 Z14MenuSelectCoreP8MenuData5PointdmPP13OpaqueMenuRefPt + 640 (in HIToolbox) [0x934924ec]

116 Z19FinishMenuSelectionP8MenuDataS0_P10MenuResultS2_mmmh + 162 (in HIToolbox) [0x934b595e]

116 _SendMenuItemSelectedEvent + 134 (in HIToolbox) [0x934b5a4c]

116 _SendMenuCommandWithContextAndModifiers + 59 (in HIToolbox) [0x934b5a8f]

116 Z18SendHICommandEventmPK9HICommandmmhP20OpaqueEventTargetRefS3_PP14OpaqueEventRef + 411 (in HIToolbox) [0x9348f23d]

116 _SendEventToEventTarget + 52 (in HIToolbox) [0x9345aed2]

116 Z30SendEventToEventTargetInternalP14OpaqueEventRefP20OpaqueEventTargetRefP14HandlerCallRec + 405 (in HIToolbox) [0x9343e57d]

116 Z23DispatchEventToHandlersP14EventTargetRecP14OpaqueEventRefP14HandlerCallRec + 1181 (in HIToolbox) [0x9343f143]

116 Z17qt_mac_menu_eventP25OpaqueEventHandlerCallRefP14OpaqueEventRefPv + 617 (in QtGuiVBox) [0x16cc529]

116 Z22qt_mac_activate_actionP13OpaqueMenuRefjN7QAction11ActionEventEb + 153 (in QtGuiVBox) [0x16cbf19]

116 ZN7QAction8activateENS_11ActionEventE + 159 (in QtGuiVBox) [0x124c82f]

116 ZN7QAction9triggeredEb + 76 (in QtGuiVBox) [0x124acac]

116 ZN11QMetaObject8activateEP7QObjectiiPPv + 528 (in QtCoreVBox) [0x11113f0]

116 ZN15VBoxSelectorWnd11qt_metacallEN11QMetaObject4CallEiPPv + 1159 (in VirtualBox.dylib) [0x4b8b07]

116 ZN15VBoxSelectorWnd12fileMediaMgrEv + 25 (in VirtualBox.dylib) [0x3f3559]

116 ZN19VBoxMediaManagerDlg12showModelessEP7QWidgetb + 427 (in VirtualBox.dylib) [0x49e77b]

116 ZN19VBoxMediaManagerDlg5setupEN8VBoxDefs9MediaTypeEbbRK8CMachineRK5QUuidb + 1899 (in VirtualBox.dylib) [0x49e5cb]

116 ZN10VBoxGlobal21startEnumeratingMediaEv + 167 (in VirtualBox.dylib) [0x3c51c7]

116 Z18AddHardDisksToListRK7QVectorI9CHardDiskER11QLinkedListI10VBoxMediumENS6_8iteratorEPS5_ + 393 (in VirtualBox.dylib) [0x3c47f9]

116 ZN10VBoxMedium7refreshEv + 115 (in VirtualBox.dylib) [0x4a2283]

116 ZN14nsXPTCStubBase5Stub3Ev + 54 (in VBoxXPCOM.dylib) [0x1eb388a]

116 Z18PrepareAndDispatchP14nsXPTCStubBasejPj + 362 (in VBoxXPCOM.dylib) [0x1eb380e]

116 ZN12DConnectStub10CallMethodEtPK15nsXPTMethodInfoP17nsXPTCMiniVariant + 1316 (in VBoxXPCOMIPCC.dylib) [0x75a3ba]

116 Z15IPC_WaitMessagejRK4nsIDP19ipcIMessageObserverS3_j + 262 (in VBoxXPCOMIPCC.dylib) [0x752b52]

116 Z10WaitTargetRK4nsIDjPP10ipcMessagePFiPvP13ipcTargetDataPKS2_ES5_ + 427 (in VBoxXPCOMIPCC.dylib) [0x7527e7]

116 _PR_Wait + 57 (in VBoxXPCOM.dylib) [0x1ebb5b9]

116 _PR_WaitCondVar + 107 (in VBoxXPCOM.dylib) [0x1ebb2ef]

116 _pt_TimedWait + 166 (in VBoxXPCOM.dylib) [0x1ebaf9c]

116 _semaphore_timedwait_signal_trap + 10 (in libSystem.B.dylib) [0x90c6e226]

Thread id: 9fc54f0 User stack:

116 _thread_start + 34 (in libSystem.B.dylib) [0x90c9ef52]

116 pthread_start + 321 (in libSystem.B.dylib) [0x90c9f095]

116 Z18rtThreadNativeMainPv + 132 (in VBoxRT.dylib) [0x33c514]

116 _rtThreadMain + 64 (in VBoxRT.dylib) [0x3103e0]

116 pt_iprt_root + 141 (in VBoxXPCOM.dylib) [0x1eda8e5]

116 _WaitPidDaemonThread + 325 (in VBoxXPCOM.dylib) [0x1eeddd8]

116 _PR_WaitCondVar + 89 (in VBoxXPCOM.dylib) [0x1ebb2dd]

116 _semaphore_wait_signal_trap + 10 (in libSystem.B.dylib) [0x90c6e20e]

Thread id: 9791998 User stack:

116 _thread_start + 34 (in libSystem.B.dylib) [0x90c9ef52]

116 pthread_start + 321 (in libSystem.B.dylib) [0x90c9f095]

116 Z18rtThreadNativeMainPv + 132 (in VBoxRT.dylib) [0x33c514]

116 _rtThreadMain + 64 (in VBoxRT.dylib) [0x3103e0]

116 pt_iprt_root + 141 (in VBoxXPCOM.dylib) [0x1eda8e5]

116 Z10ConnThreadPv + 94 (in VBoxXPCOMIPCC.dylib) [0x75c14e]

116 _PR_Poll + 975 (in VBoxXPCOM.dylib) [0x1ed3e75]

116 _select$DARWIN_EXTSN$NOCANCEL + 10 (in libSystem.B.dylib) [0x90ca530a]

Thread id: 9fc45d0 User stack:

116 _thread_start + 34 (in libSystem.B.dylib) [0x90c9ef52]

116 pthread_start + 321 (in libSystem.B.dylib) [0x90c9f095]

116 Z18rtThreadNativeMainPv + 132 (in VBoxRT.dylib) [0x33c514]

116 _rtThreadMain + 64 (in VBoxRT.dylib) [0x3103e0]

116 pt_iprt_root + 141 (in VBoxXPCOM.dylib) [0x1eda8e5]

116 ZN8nsThread4MainEPv + 45 (in VBoxXPCOM.dylib) [0x1ea72e3]

116 ZN14DConnectWorker3RunEv + 164 (in VBoxXPCOMIPCC.dylib) [0x75ba3c]

116 _PR_Wait + 57 (in VBoxXPCOM.dylib) [0x1ebb5b9]

116 _PR_WaitCondVar + 89 (in VBoxXPCOM.dylib) [0x1ebb2dd]

116 _semaphore_wait_signal_trap + 10 (in libSystem.B.dylib) [0x90c6e20e]

Thread id: 7304208 User stack:

116 _thread_start + 34 (in libSystem.B.dylib) [0x90c9ef52]

116 pthread_start + 321 (in libSystem.B.dylib) [0x90c9f095]

116 _PrivateMPEntryPoint + 56 (in CarbonCore) [0x96ec10a3]

116 ZN23TSystemNotificationTask26SystemNotificationTaskProcEPv + 123 (in DesktopServicesPriv) [0x92da0e83]

116 _CFRunLoopRun + 84 (in CoreFoundation) [0x96332d34]

116 _mach_msg_trap + 10 (in libSystem.B.dylib) [0x90c6e1c6]

Thread id: 9fc6ba0 User stack:

116 _thread_start + 34 (in libSystem.B.dylib) [0x90c9ef52]

116 pthread_start + 321 (in libSystem.B.dylib) [0x90c9f095]

116 _PrivateMPEntryPoint + 56 (in CarbonCore) [0x96ec10a3]

116 ZN25TFSEventsNotificationTask28FSEventsNotificationTaskProcEPv + 216 (in DesktopServicesPriv) [0x92da0ffc]

116 _CFRunLoopRun + 84 (in CoreFoundation) [0x96332d34]

116 _mach_msg_trap + 10 (in libSystem.B.dylib) [0x90c6e1c6]

Thread id: 9fc3e40 User stack:

116 _thread_start + 34 (in libSystem.B.dylib) [0x90c9ef52]

116 pthread_start + 321 (in libSystem.B.dylib) [0x90c9f095]

116 _PrivateMPEntryPoint + 56 (in CarbonCore) [0x96ec10a3]

116 ZN13TNodeSyncTask12SyncTaskProcEPv + 84 (in DesktopServicesPriv) [0x92dabfba]

116 _MPWaitOnQueue + 208 (in CarbonCore) [0x96ec2b4c]

116 _TSWaitOnConditionTimedRelative + 202 (in CarbonCore) [0x96ea1da6]

116 _TSWaitOnCondition + 126 (in CarbonCore) [0x96ec2ecf]

116 _semwait_signal + 10 (in libSystem.B.dylib) [0x90c753ae]

Thread id: 9fc4d60 User stack:

116 _thread_start + 34 (in libSystem.B.dylib) [0x90c9ef52]

116 _kevent + 10 (in libSystem.B.dylib) [0x90c9e906]

Thread id: 9ff77d8 User stack:

116 _thread_start + 34 (in libSystem.B.dylib) [0x90c9ef52]

116 _select + 10 (in libSystem.B.dylib) [0x90cbd6f2]

Thread id: 9793048 User stack:

116 _thread_start + 34 (in libSystem.B.dylib) [0x90c9ef52]

116 pthread_start + 321 (in libSystem.B.dylib) [0x90c9f095]

116 _NSThreadmain + 308 (in Foundation) [0x90eef394]

116 -[NSThread main] + 45 (in Foundation) [0x90eef7ed]

116 -[NSUIHeartBeat _heartBeatThread:] + 753 (in AppKit) [0x93b6ad90]

116 -[NSConditionLock lockWhenCondition:] + 69 (in Foundation) [0x90f354d5]

116 -[NSConditionLock lockWhenCondition:beforeDate:] + 144 (in Foundation) [0x90f35570]

116 -[NSCondition waitUntilDate:] + 236 (in Foundation) [0x90f3575c]

116 _semaphore_timedwait_signal_trap + 10 (in libSystem.B.dylib) [0x90c6e226]

Thread id: 9fc6048 User stack:

115 _thread_start + 34 (in libSystem.B.dylib) [0x90c9ef52]

115 pthread_start + 321 (in libSystem.B.dylib) [0x90c9f095]

115 _PrivateMPEntryPoint + 56 (in CarbonCore) [0x96ec10a3]

115 ZN15TFolderSizeTask18FolderSizeTaskProcEPv + 104 (in DesktopServicesPriv) [0x92dadf04]

115 _MPWaitOnQueue + 208 (in CarbonCore) [0x96ec2b4c]

115 _TSWaitOnConditionTimedRelative + 246 (in CarbonCore) [0x96ea1dd2]

115 _semaphore_timedwait_signal_trap + 10 (in libSystem.B.dylib) [0x90c6e226]

comment:2 Changed 5 years ago by FrankVanDamme

I suppose such dump is useful, could someone please tell me how to generate this for vbox on Mac? Thank you.

comment:3 in reply to: ↑ description ; follow-up: ↓ 5 Changed 5 years ago by pcc@…

Replying to FrankVanDamme:

I am running virtualbox on OS X.

How long should one wait for an import of an 8GB image? I also see a 'hang' on ovf import on a 3GHz P4 desktop box where the VBox processes appear mostly idle (created on a T61 laptop, Core2 Duo, 2 GB RAM, both VBox V2.2.2 on WinXP Professional Version 2002 SP2).

Is there a way to gather further information, what would you like to see?

Regards,

Peter.

comment:4 Changed 5 years ago by barmanoo

Same problem for me with VirtualBox 2.2.2 r46594

I created a VM under Ubuntu 9.04 (32 bits) with windows XP Pro guest and exported it without legacy OVF 0.9. I moved this VM on Windows XP Pro and import it well under the administrative account.

When I tried to import the same VM under a single user account the program hang on after 90% (I tried also under cmd with VBOXManage with same result)

Regards

Olivier Friard

comment:5 in reply to: ↑ 3 ; follow-up: ↓ 6 Changed 5 years ago by pcc@…

Replying to pcc@gmx.net:

(...) I also see a 'hang' on ovf import on a 3GHz P4 desktop box where the VBox processes appear mostly idle (created on a T61 laptop, Core2 Duo, 2 GB RAM, both VBox V2.2.2 on WinXP Professional Version 2002 SP2).

I don't know how relevant this is, but I deinstalled VBox V2.2.2 and installed V2.2.0 since that was the version where the import feature initially has been introduced. Interestingly, I had an immediate failure the first time I tried:

AppName: vboxsvc.exe AppVer: 2.2.0.0 ModName: vboxsvc.exe ModVer: 2.2.0.0 Offset: 0005837c

Unfortunately, Windows did not want me to have the .dmp file that went with it, and I currently cannot reproduce this situation.

In parallel, however, I have an error which I believe has to do with remaining registry entries of the higher V2.2.2:

Código Resultado: E_INVALIDARG (0x80070057) Componente: VirtualBox Interface: IVirtualBox {779264f4-65ed-48ed-be39-518ca549e296}

This appears to be repeatable at all times and prevents any further progress.

comment:6 in reply to: ↑ 5 Changed 5 years ago by pcc@…

Replying to pcc@gmx.net:

Replying to pcc@gmx.net:

(...) I also see a 'hang' on ovf import on a 3GHz P4 desktop box where the VBox processes appear mostly idle (created on a T61 laptop, Core2 Duo, 2 GB RAM, both VBox V2.2.2 on WinXP Professional Version 2002 SP2).

V2.2.4 seems to resolve this matter for me, thank you.

All the best,

Peter.

comment:7 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use