VirtualBox

Ticket #3872 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

VM Aborts during boot on Fedora 11 x86_64 => update F11 package

Reported by: seandarcy Owned by:
Priority: major Component: other
Version: VirtualBox 2.2.2 Keywords: boot abort
Cc: Guest type: Windows
Host type: Linux

Description (last modified by frank) (diff)

I have vbox on Fedora 11 x86_64 with 2 vm's, windows 7 and xp.

I set them up and ran them under 2.2.0. rpm -Uvh --nodeps.

Installed 2.2.2, no problem. One vm - xp - was saved. Started it up, worked fine. Shut it down to change settings to allow VRDP.

But now when I start either vm, I get the bios screen, a message that the vm couldn't find any audio, then it aborts.

I went back and turned off VRDP. Same result.

Attached is the log.

I tried to get a core dump:

As root:

[root@intel64-office ~]# ulimit -c unlimited
[root@intel64-office ~]# echo -n 1 > /proc/sys/fs/suid_dumpable
[root@intel64-office ~]# /usr/lib/virtualbox/VirtualBox -startvm Windows-XP

The VM boot window showed up, same dialogs, then aborts. But no core dump:

[root@intel64-office ~]# ls
anaconda-ks.cfg  Music      <unknown>-bugreport.txt
Desktop          Pictures   Videos
Documents        Public     Windows-XP-2009-04-28-21-51-54.log
Download         Templates

sean

Attachments

Windows-XP-2009-04-28-21-55-27.log Download (33.8 KB) - added by seandarcy 5 years ago.
VBox.log Download (32.7 KB) - added by asavva 5 years ago.

Change History

Changed 5 years ago by seandarcy

comment:1 Changed 5 years ago by asavva

I have the exact same problem.

I upgraded to F11 and subsequently upgraded VirtualBox to the F11 version.

I successfully started VirtualBox after the upgrade and managed to start my virtual machine (Windows XP Professional) once. I then restarted it and got an abort. I've not been able to restart the machine despite several attempts at changing settings in the VM.

Rebooting the VirtualMachine puts it in a bad state such that it's impossible to restart again.

Unlike the guy above I did not change any settings, I simply restarted the virtual machine and it corrupted.

I don't get any error messages, it's nothing to do with the audio or the VRDP setting.

Changed 5 years ago by asavva

comment:2 follow-up: ↓ 3 Changed 5 years ago by frank

  • Description modified (diff)

Cannot reproduce any crash on F11/x86_64. Please could you check  this page on how to create a core dump? Please contact me by private E-mail if you have something (frank _dot_ mehnert _at_ sun _dot_ com).

comment:3 in reply to: ↑ 2 Changed 5 years ago by asavva

Replying to frank:

Cannot reproduce any crash on F11/x86_64. Please could you check  this page on how to create a core dump? Please contact me by private E-mail if you have something (frank _dot_ mehnert _at_ sun _dot_ com).

I've sent the core dump by email.

comment:4 Changed 5 years ago by frank

Thanks asawa. Finally I was reproduce this problem. Happens when booting the VM with VT-x/AMD-V disabled (this happens if this extension is not available).

comment:5 Changed 5 years ago by frank

  • Summary changed from vb-2.2.2: vm aborts on boot on Fedora 11 x86_64 to VM Aborts during boot on Fedora 11 x86_64 => update F11 package

We think we found the problem. That crash seems to be related to gcc-4.4 builds for AMD64 hosts. I've replaced the F11 package, please could you acknowledge that  this package (not the in the package name) allows you to boot your VMs?

comment:6 Changed 5 years ago by frank

s/not the in the package name/note the -2 in the package name/

comment:7 Changed 5 years ago by asavva

I'm at work at the moment but as soon as I get home I'll check it out.

Cheers, Andrew

comment:8 follow-up: ↓ 9 Changed 5 years ago by cedricv

Works for me! :-)

I ve had the exact same issue (FWIW it aborted whether VT-x/AMD-V enabled or not)

Thanks Frank for the quick fix.

comment:9 in reply to: ↑ 8 Changed 5 years ago by asavva

Replying to cedricv:

Works for me! :-)

I ve had the exact same issue (FWIW it aborted whether VT-x/AMD-V enabled or not)

Thanks Frank for the quick fix.

Yep, works for me too.

Many thanks!

comment:10 Changed 5 years ago by seandarcy

Also WFM.

Thanks.

sean

comment:11 Changed 5 years ago by cedricv

Is this fix present in 2.2.4? Cannot find a reference to it in the ChangeLog.

comment:12 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

We didn't explicitly mention this in the changelog because the updated F11 package for 2.2.2 fixed this as well. The F11 package for 2.2.4 should work as well of course. Closing.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use