VirtualBox

Ticket #3858 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

VM hangs immediately if USB device is activated via configuration file before starting

Reported by: DrScott Owned by:
Priority: major Component: USB
Version: VirtualBox 2.2.0 Keywords:
Cc: Guest type: other
Host type: other

Description

I've set up a virtual machine using VB 2.1. Host is Ubuntu Hardy (8.04), guest is WindowsXP. I own a HP C4280 printer which is connected via USB to the host. I added an activated DeviceFilter for this Device. This configuration works perfect with VB 2.1.

Note that i had to make sure, that VirtualBox has all needed rights for accessing the Host USB system. I have achieved this by adding

none /proc/bus/usb usbfs devgid=124,devmode=664 0 0

to my /etc/fstab. (Without that modification the Printer is listed as Device, but "greyed" and therefore cannot be captured/activated withing the guest).

So this describes my perfectly running configuration using VB2.1

Now i upgraded to VB2.2 and the virtual machine doesn't start anymore: The VM window appears, a progressbar appears saying "Starting virtual machine 0% " and stalls forever - no progress. Please find attached a screenshot and a logfile, both taken in this situation. Even the "splash screen" of VirtualBox's BIOS (the blue one) doesn't show up, so i assume it hangs even before that and thus this bug is not guest related (i double checked it with a hard-disk-less VM: Same result: No BIOS screen). Neither the VM window nor the VirtualBox main windows reponds anymore. I have to kill their processes.

In the XML file of the virtual machine there is a DeviceFilter element for the printer. If i change its attribute 'active' to 'false', then VB is able to start the VM and the guest boots correctly. As soon as possible i am able to activate the USB Device manually. So the problem occours only, if the Device is activated by configuration. This is a regression to 2.1

Do you need any further information?

btw.:Im aam not sure, but this one seems similar to bug #3436

Attachments

VBox.log Download (30.3 KB) - added by DrScott 5 years ago.
Problem.png Download (23.1 KB) - added by DrScott 5 years ago.

Change History

Changed 5 years ago by DrScott

Changed 5 years ago by DrScott

comment:1 Changed 5 years ago by DrScott

This is fixed by VB 2.2.2.

This is a duplicate of bug #3787

comment:2 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Thanks for the feedback.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use