VirtualBox

Ticket #3844 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

Crosshairs in AutoCad sluggish

Reported by: mcp Owned by:
Priority: major Component: other
Version: VirtualBox 2.2.0 Keywords: Autocad
Cc: Guest type: Windows
Host type: Linux

Description

I use a Wacom tablet as my mouse in Klikit Linux (based on Kbuntu). It is this mouse that is captured by VB in my guest (XP Pro sp2) where I run AutoCad. When I upgraded to VB 2.2 I found that the crosshair cursor lags behind the movement of the mouse severely. Ver 2.04 of VB works acceptably with this arrangement, although improvement would be appreciated. Switching from seamless to windowed mode did improve it but not a lot. The only way I found to make it workable was to change the cursor from 100% crosshair to 5%. But even with this setting the cursor had other problems which make it difficult to work with. I had to downgrade back to 2.04.

Change History

comment:1 in reply to: ↑ description Changed 5 years ago by mcp

Replying to mcp:

I use a Wacom tablet as my mouse in Klikit Linux (based on Kbuntu). It is this mouse that is captured by VB in my guest (XP Pro sp2) where I run AutoCad. When I upgraded to VB 2.2.0 I found that the crosshair cursor lags behind the movement of the mouse severely. Ver 2.1.4 of VB works acceptably with this arrangement, although improvement would be appreciated. Switching from seamless to windowed mode did improve it but not a lot. The only way I found to make it workable was to change the cursor from 100% crosshair to 5%. But even with this setting the cursor had other problems which make it difficult to work with. I had to downgrade back to 2.1.4.

UPDATE: I just upgraded to 2.2.2 and found that my problem is largely the same as with 2.2.0. I do find that my Autocad is usable if I keep the crosshairs to 5% and keep the 2.1.4GA.

comment:2 Changed 5 years ago by evaldes

I am running VirtualBox 2.2.2 on Fedora 9 x86 with a Windows XP guest. I have a similar graphics performance problem in FastCad. The crosshair is slow and jerky. The performance was fine under VirtualBox 2.1.4.

comment:3 Changed 5 years ago by mcp

To UPDATE: I am currently running Vbox 3.0 and the crosshairs are improved but still seem to be a bit sluggish. The feeling is one of floating with out mouse movement. When I click on a point in order to draw or move an entity the mouse click is not registered immediately resulting in misplaced objects and more work.

comment:4 Changed 4 years ago by mcp

I recently updated my linux install to PCLOS 2009 and installed KDE4. Since upgrading to KDE4 I no longer experience this problem. I'm now using VBox 3.0.10 with lastest GA without problems.

comment:5 Changed 4 years ago by klaus

  • Status changed from new to closed
  • Resolution set to fixed

Closing, as there are reports the problem is gone. Reopen if it shows up again.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use