VirtualBox

Ticket #3833 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

Host Crashes on VM Exit

Reported by: boldingd Owned by:
Priority: major Component: other
Version: VirtualBox 2.2.0 Keywords:
Cc: Guest type: other
Host type: Linux

Description

When any Guest exits, the kernel panics. No logs seem to survive the reboot (/var/log/vbox/ is empty), and no diagnostic messages are printed. I have installed VirtualBox on a RedHat Enterprise Linux 4, 64-bit host: the machine is a Core 2, Quad-Core. Though I have VT-x enabled, I have left the rest of the virtualization-related features of my system off. The crash seems to occur regardless of whether ACPI is on or off, whether Nested Paging is on or off, regardless of whether Guest Additions have started or not, and regardless of the guest (I have a Windows XP 32-bit guest and a Sidux Linux 32-bit guest, both of which cause the crash). If memory serves, the crash occurs even if VT-x is off on the Guest, though I do not think it occurred when I had VT-x disabled in the BIOS. As I said, no log files seem to survive the restart, so there are no additional files that I can provide.

Attachments

vbox_log.txt Download (51.3 KB) - added by meah 5 years ago.
XP-2009-07-06-16-27-48.log Download (58.8 KB) - added by meah 5 years ago.

Change History

comment:1 Changed 5 years ago by meah

I can confirm this. same os with 2 Xeon Core2Quad. If i enable VT-X a system crash occurs without VT-X no crash. No systems log informations available - systems has no time to write any information to disk. vbox.log seems to stop successfully.

Changed 5 years ago by meah

comment:2 Changed 5 years ago by meah

Actually the vbox.log is not complete (due to the crash). i will attach a 'complete' vbox.log

Changed 5 years ago by meah

comment:3 Changed 5 years ago by frank

So looks like a problem with VT-x. There were several VT-x-related fixes in 3.0.0 / 3.0.2, please could you check the latest release (3.0.2)?

comment:4 Changed 5 years ago by meah

it happens also on ver 3.0.2 (without VT-X works)

comment:5 Changed 5 years ago by boldingd

I still have the crash myself, with VirtualBox 3.02 also.

comment:6 Changed 5 years ago by boldingd

Oh -- and I was wrong in the bug report above: even if VT-X is enabled in the host's BIOS, if VT-X usage is off for the guest, it exits fine, no crash. It is only if VT-X usage is enabled in the guest that there is a crash.

comment:7 Changed 4 years ago by Technologov

Basically it looks like a conflict between vboxdrv and ancient Linux host kernel.

I suggest upping this bug to "blocker" status, because it crashes Host.

-Technologov

comment:8 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if still relevant. There were some fixes for older Linux 2.6 kernels in 3.0/3.1.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use